We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Load on hold

I have a problem with the sfpdfviewer component,

when I am in debug everything works regularly but when I publish my webassembly app on IIS and I try to open the pdf, the component is uselessly waiting.

I noticed that upon inspecting the page in debug mode the request URL address is correct (http://localhost:51675/pdfviewer/Load)

while if I inspect the page published on IIS the request URL address is duplicated!

(http://95.110.115.121:65512/ 95.110.115.121:65512/pdfviewer/Load)

thank you


3 Replies

VV Visvesvar Venkatesan Syncfusion Team November 8, 2022 12:11 AM

While trying to run a web service sample.


We need to follow the below steps.


1) Host your web service.


2) Kindly paste the service URL in the service URL property and run the sample locally.


3) And then publish the sample.


4) Then load the Document.


This will resolve your issue. If not kindly send us the sample you have tried and the hosted URL which can be able to access by us if possible.




EG egidio November 8, 2022 02:06 PM

I solved the problem!

You only need to enter the name of the service without the site address


<SfPdfViewer @ref="@viewer" Width="Auto" Height="800px" ServiceUrl=" /pdfviewer " />

and not  95.110.115.121:65512/pdfviewer



VV Visvesvar Venkatesan Syncfusion Team November 9, 2022 11:49 PM

Thank you for your update


Loader.
Live Chat Icon For mobile
Up arrow icon