We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Datagrid custom aggregate functions called many times

What might I be doing incorrectly that causes the aggregate functions on a datagrid to be called dozens of times? The result is correct each time but I can't understand what is causing it to fire so many times. This is the case with a footer aggregate and a custom aggregate.

Thanks


2 Replies

SP Sarveswaran Palani Syncfusion Team November 7, 2022 10:07 PM

Hi Sheldon,

We are currently Validating the reported query with high priority at our end, and we will update the further details on or before 10th November 2022. Until then we appreciate your patience.


Regards,
Sarveswaran PK



SP Sarveswaran Palani Syncfusion Team November 8, 2022 10:29 PM

Hi Sheldon,


From your query, we have created sample based on your requirement using custom aggregation, but we’re unable to reproduce reported issue at our end. Kindly refer the attached video demo and UG documentation link for your reference.


Reference: https://blazor.syncfusion.com/documentation/datagrid/aggregates#custom-aggregate


And also, share the following details for further validation.


  1. Mention what are the actions used in your project?
  2. Share the video demo of an issue
  3. Or share the code snippet or simple issue reproducible sample to us.


Above requested details will be helpful for us to validate the reported query at our end and provide solution as early as possible. 


Regards,

Sarvesh


Loader.
Live Chat Icon For mobile
Up arrow icon