We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Strict Mode not working in sfDatePicker

I am trying to disable "Past Date" using strict-mode in sfDatepicker.I have refer below link but its not working

https://blazor.syncfusion.com/documentation/datepicker/strict-mode

Note:-

I have tried in two scenario

1.I have set MinDate = Todays and Strict Mode = false ----> It disabled the past date but user can change date in keyboard for past date

2. When I set Strict Mode = true and  MinDate = Todays, then its not working --- > It's normal mode (user can enter any date here)


I am using syncfussion 20.3.0.53



2 Replies

KI KINS November 1, 2022 07:45 AM

awaiting for reply...



SP Sureshkumar P Syncfusion Team November 1, 2022 09:13 AM

Hi KINS,

As per our documentation when setting the strictMode as true we cannot allow the out-of-range value in between the Min and Max property values. So, in your scenario, the past dates are not allowed when setting the strictMode property value as true.

Regards,

Sureshkumar P


Loader.
Live Chat Icon For mobile
Up arrow icon