We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

DataManagerRequest Take shows default value as 30

Hi,


My query is when the Datagrid is loaded the paging does not show the correct page size or page count. On debugging the UrlAdaptor method got to know the Take value for DataManangerRequest has a default value is 30. only after you select the page number or select value from the page size drop-down it shows the correct count. it impacts the filter functionality as well. Kindly help.


5 Replies 1 reply marked as answer

JC Joseph Christ Nithin Issack Syncfusion Team October 24, 2022 11:38 AM

Hi Sidhartha,


  Greetings from Syncfusion support.


  Based on your query, when you load the grid initially, the take value for DataManangerRequest is 30. We have validated your query, but we were not able to reproduce the issue from our side. We have shared the screenshot and sample for your reference.


Screenshot:


Sample: https://www.syncfusion.com/downloads/support/directtrac/general/ze/mvc-url-adaptor-paging-489786982


If you still face the issue, kindly share a issue replicating sample or try to reproduce the issue in the sample provided.


Please get back to us for further details.


Regards,

Joseph I.



SI Sidhartha October 25, 2022 08:52 AM

for me now it's showing take as 60. Please refer to the screenshot attached.


Take60 (Phone).jpeg

I have even provided pageSizer=20 from cshtml. 

Take60_take (Phone).png



PS Pavithra Subramaniyam Syncfusion Team October 26, 2022 07:48 AM

Hi Sidhartha,


From the shared Grid code, we could see that you are enabling both “Infinite Scrolling” and “Paging” features in same Grid which is the cause of the reported scenario. We recommend enabling any one of the features to make Grid work properly. If you want to use the “Infinite Scrolling” feature, then the Grid will load three-page records by default. So, if you set the pageSize as 20 then the take parameter will be 60. Or If you are using the only “Paging” feature then the “take” parameter will be sent as per the “pageSize” property. Please refer to the below documentation link for more information.


https://ej2.syncfusion.com/angular/documentation/grid/infinite-scroll/#initialblocks


Please get back to us if you need further assistance on this.


Regards,

Pavithra S


Marked as answer

SI Sidhartha replied to Pavithra Subramaniyam October 28, 2022 09:11 AM

Thank you so much... it worked... I removed  Infinite Scrolling  and it worked as expected. Thank you so much



PS Pavithra Subramaniyam Syncfusion Team October 31, 2022 12:21 AM

Hi Sidhartha,


Welcome. We are glad to hear that you have achieved your requirement. Please get back to us if you need further assistance on this.


Regards,

Pavithra S


Loader.
Live Chat Icon For mobile
Up arrow icon