We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

File Manager Upload Maximum Capacity

Hello,

I setup 'maxFileSize'in filemanager.

I uploaded a file smaller than the size of"maxFileSize", but it says "Request Entity Too Large"

 Should I add another setting??


<div class="row">
    <div class="col-12">
        <ejs-filemanager id="file" path="@ViewBag.FilePath" view="Details" allowDragAndDrop="false" height="800" fileOpen="doubleClick" success="loadSuccess">
            <e-filemanager-ajaxsettings url="/FileManager/FileOperations?sMenu=Calculation" , downloadUrl="/FileManager/Download?sMenu=Calculation" , uploadUrl="/FileManager/Upload?sMenu=Calculation"></e-filemanager-ajaxsettings>
            <e-filemanager-contextmenusettings visible="true"></e-filemanager-contextmenusettings>
            <e-filemanager-navigationpanesettings visible="false"></e-filemanager-navigationpanesettings>
            <e-filemanager-toolbarsettings visible="true"></e-filemanager-toolbarsettings>
            <e-filemanager-uploadsettings maxFileSize="209715200" autoUpload="false" ></e-filemanager-uploadsettings>
        </ejs-filemanager>
    </div>
</div>

2 Replies

TK TaeWook Kang October 20, 2022 09:11 PM

attachment

이미지 3.png

이미지 4.png



PM Prasanth Madhaiyan Syncfusion Team October 21, 2022 03:24 AM

Hi TaeWook,


Greetings from Syncfusion support.


We have validated your reported query in the ASP.NET Core FileManager component by preparing the sample. We understand that you are facing issues while uploading a larger file in the FileManager. By default upload size of the FileManager component is 30MB. After enabling the uploadSettings and setting the maxFileSize value as “524288000, we are unable to reproduce the reported issue. We were able to upload the files larger than 60MB in the Physical File service provider at our end. Check the below screenshot.



Refer to the below code snippet. 


[index.cshtml]

 

<ejs-filemanager id="filemanager" view="@Syncfusion.EJ2.FileManager.ViewType.Details">

    <e-filemanager-ajaxsettings url=http://localhost:62869/api/FileManager/FileOperations

                                downloadUrl=http://localhost:62869/api/FileManager/Download

                                uploadUrl=http://localhost:62869/api/FileManager/Upload

                                getImageUrl=http://localhost:62869/api/FileManager/GetImage>

    </e-filemanager-ajaxsettings>

                <e-filemanager-uploadsettings minFileSize="0" maxFileSize="524288000" autoUpload="false" ></e-filemanager-uploadsettings>

</ejs-filemanager>

 

[web.config]

<security> 

      <requestFiltering> 

        <requestLimits maxAllowedContentLength="1073741824" ></requestLimits> 

      </requestFiltering> 

    </security> 


For your reference, we have attached the sample and Physical File Service Provider.


Sample: https://www.syncfusion.com/downloads/support/directtrac/general/ze/CoreFileManager1471386512.zip


Provider: https://www.syncfusion.com/downloads/support/directtrac/general/ze/PhysicalFileProvider-1760058453.zip


Also, if you want to increase the file size on the server side, please refer to the following link.


https://www.talkingdotnet.com/how-to-increase-file-upload-size-asp-net-core/ 


Please check the shared details. If the issue persists, please revert with an issue-replicated sample along with an error stack trace. Have you done any customizations for the Upload file operation at the server end? These details would help us with further validation and provide a prompt resolution. Let us know if you need any further assistance.


Regards,

Prasanth Madhaiyan.


Loader.
Live Chat Icon For mobile
Up arrow icon