TypeError: Cannot read property 'startDate' of undefined
Hi
Very sometime the scheduler doesn't work after first startup.
Then when we navigate, the scheduler stays on the same day.
We're using version 18.4.30
the error we have in the console is from the scheduler component.
this is the error msg :
TypeError: Cannot read property 'startDate' of undefined
at e.refreshDataManager (chunk-vendors.c69e6b7e.js:28)
at t.propertyChangeAction (chunk-vendors.c69e6b7e.js:28)
at t.onPropertyChanged (chunk-vendors.c69e6b7e.js:28)
at t.e.dataBind (chunk-vendors.c69e6b7e.js:28)
at t.dataBind (chunk-vendors.c69e6b7e.js:28)
at s.t.dataBind (chunk-vendors.c69e6b7e.js:38)
at s. (chunk-vendors.c69e6b7e.js:38)
at tn.run (chunk-vendors.c69e6b7e.js:14)
at Ki (chunk-vendors.c69e6b7e.js:14)
at Array. (chunk-vendors.c69e6b7e.js:14)
rt @ chunk-vendors.c69e6b7e.js:14
Any idea's why this is happening ?
We load the scheduler events data in the activated: function ()
90% of the time its ok..
Regards
Peter.
SIGN IN To post a reply.
3 Replies
1 reply marked as answer
HB
Hareesh Balasubramanian
Syncfusion Team
December 22, 2020 10:30 AM UTC
Hi Peter,
Greetings form Syncfusion Support..!
We have prepared a sample based on your shared query “Then when we navigate, the scheduler stays on the same day” with current(18.4.30) version and also we have ensured the Scheduler date navigation on different views unfortunately it is properly navigating at our side and the same can be downloaded from the following link.
Kindly try the above sample and if the issue still persists at your end kindly share the below details to serve you better?
- Kindly share the scheduler rendering code snippets.
- Replicate the issue in the above sample.
- Share the issue replicating sample (if possible)
We will happy to assist you.
Regards,
Hareesh
Marked as answer
PE
Peter
December 23, 2020 08:47 PM UTC
Hi
Thanks for the information.
I have found and solved my problem.
After testing in Google chrome development with slow connection setup, i could simulate the problem.
The issue was that the scheduler (with resources) , the users where sometimes loaded after the remote events.
Then i got this issue.
So i have solved it with first loading the resources in the scheduler and with an callback fucntion then the events..
Regards
Peter.
VM
Vengatesh Maniraj
Syncfusion Team
December 24, 2020 06:57 AM UTC
Hi Peter,
Thanks for the update.
We are happy that you have found the solution.
Please get back to us if you need any further assistance.
Regards,
Vengatesh
SIGN IN To post a reply.