We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Docking and scrollbars

Hello, I have several user controls in a docking manager that are showing scrollbars. How do I turn off the docking manager scrollbars and let the control manage its own?

2 Replies

AD Administrator Syncfusion Team June 30, 2004 05:46 AM

Hi Justin, Could you please provide more information on what you are doing?. Docking manager does not show any scrollbars, The controls that are docked inside manage their own scrollbars. Are you referring to the DockClientPanel?. Please clarify. Thanks. Best regards, Stephen. >Hello, > >I have several user controls in a docking manager that are showing scrollbars. How do I turn off the docking manager scrollbars and let the control manage its own?


JK Justin Koh June 30, 2004 01:08 PM

Well, I have AutoScroll set to false on my user controls. In my main form , I draw a panel and then set "Enable docking on dmMain" (dmMain is the docking Manager). Now, I am having a hard time with these panels. All of them have their autoscroll set to false, yet they show scroll bars. Any ideas? Also, I am experimenting with saving the dockstream to a resource file and then setting the frmMain.resx file''s docklayoutstream to be this new value (it''s easier to work w/ the docking manager when the thing is running, rather than design mode). I''m trying two approaches: saving the docklayoutstream to a new resource (which doesn''t seem to take into account some changes which are taken into account with the native Syncfusion persistDockState method) and also just calling dmMain.SaveDockState w/ an AppStateSerializer. Is there a better way?

Loader.
Live Chat Icon For mobile
Up arrow icon