We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Blazor platform licensing validation issue - Version 17.4.0.39

Thread ID:

Created:

Updated:

Platform:

Replies:

157219 Dec 19,2019 10:47 AM UTC Aug 31,2020 11:43 AM UTC Others 8
loading
Tags: Others
Administrator [Syncfusion]
Asked On December 19, 2019 12:05 PM UTC


The Blazor platform has a licensing validation issue. To resolve this issue, please follow this KB article Link.  This issue arises only when you use the Blazor NuGet package version 17.4.0.39 from nuget.org. We are working to resolve the issue with high priority. We will resolve and confirm by 20th December 2019. 

 

Regards,

Syncfusion Blazor Team.



Administrator [Syncfusion]
Replied On December 23, 2019 11:03 AM UTC

This issue resolved and updated in nuget.org on 20th December 2019. If you installed the Syncfusion.Licensing package on or before 20th December 2019, please clear NuGet cache or remove the Syncfusion.Licensing version 17.4.0.39 package from NuGet cache. 



Regards,

Syncfusion Blazor Team.



Michael Wilson
Replied On August 23, 2020 11:00 PM UTC

Hi

I have a blazor synfusion app running in docker. When I use an Azure container there are no licensing issues. When I use a Linux ubuntu docker container the unlicensed banner is displayed.

Do I need to add any libs to the Linux docker image or take any other action in order for the licensing service to operate correctly?

Thank you in advance.

Michael

Kalap Johnson Peter Paulraj [Syncfusion]
Replied On August 24, 2020 01:42 PM UTC

Hi Michael,

We are trying to reproduce the issue in the same environment of yours. We will update you further details on 26th August 2020.

Regards,
Kalap Johnson Peter P.

Kalap Johnson Peter Paulraj [Syncfusion]
Replied On August 27, 2020 06:06 PM UTC

Hi Michael,

Sorry for the delay in response

We are still trying to reproduce this issue. We will update you further details on 1st September 2020.

Regards,
Kalap Johnson Peter P.

Michael Wilson
Replied On August 27, 2020 08:40 PM UTC

No problem thank you for your efforts.

Kalap Johnson Peter Paulraj [Syncfusion]
Replied On August 28, 2020 03:21 PM UTC

Hi Michael, 
 
Thanks for your patience. 

We have checked reported issue in the blazor sample with Linux ubuntu docker container and couldn’t get reproduce the issue. We suspect that you may use different license key in your application. 

Our license keys are version and platform specific. If you are using Syncfusion NuGet packages from nuget.org or trial installer, you should generate and register corresponding version and platform license key in your application to prevent the trial licensing popup. Refer the following documentation link to know more about licensing. 

https://help.syncfusion.com/common/essential-studio/licensing/license-key   
 
Also ensure that all the referenced Syncfusion assemblies\NuGet packages are on same version.  

Find below the knowledge base article to know about which version license key should use in application, 


If still the issue persist, please share us the following details to check the reported issue. 

  1. License key registered in your application
  2. Syncfusion Essential Studio version used
  3. List of Syncfusion assemblies/NuGet packages used
  4. Screenshot of the application with error.
  5. Sample application if possible.
 
Regards, 
Kalap Johnson Peter P.

Michael Wilson
Replied On August 30, 2020 08:38 AM UTC

Thank you for taking the time to evaluate my issue. 

I may be confused by your meaning of platform-specific.
I have uploaded 2 screenshots: 
The first one is my code running in visual studio on a Windows 10 PC not displaying the banner.
The second is the SAME code running on a ubuntu docker container displaying the banner.
Am I required to have a different license based on the OS platform?

Once again I really appreciate your patience with me.

Attachment: webpage_5b9acb97.zip

PS: I would like to add the NuGet packages are the same I do not have a separate build.

Kalap Johnson Peter Paulraj [Syncfusion]
Replied On August 31, 2020 11:43 AM UTC

Hi Michael,

We have created an incident under your account. You can follow up with that incident for further updates

Regards,
Kalap Johnson Peter P.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon