We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Schedule resource view is not showing tempalted appointments

Thread ID:

Created:

Updated:

Platform:

Replies:

150635 Jan 14,2020 10:20 AM UTC Jan 15,2020 11:16 AM UTC Xamarin.Forms 3
loading
Tags: SfSchedule
Kalle Bumba
Asked On January 14, 2020 10:20 AM UTC

Hello,

i have a schedule which shows custom appointments using a datatempalteselector.

Now i'm tryiung to add a resource view to that schedule. As in the documentation i added a resources property to my custom appointment class and added the necessary mappings and resources to my xaml.

When i setShowResourceView="false" i can see all of my appointments styled with my datatemplateselector.
When i setShowResourceView="true", i can see the resources view with my (unselected) resource and no appointments are shown.

Now when i select the resource i expect that the appointments are shown, but they are not shown.

What am i doint wrong here?

Regards,
  Kalle

Karthikraja Arumugam [Syncfusion]
Replied On January 15, 2020 07:26 AM UTC

Hi Kalle Bumba, 
 
Thank you for contacting Syncfusion support. 
 
Based on the provided information, we have checked the mentioned issue “Schedule Resource view not showing templated appointments” Xamarin.Forms and we unable to replicate the issue from our end. We have tested resource view with appointment template selector and ShowResourceView dynamic change and it is working fine as expected. We suspect that there may be issue with mapping in the sample. We have prepared a sample for the same, 
 
 
We have tested with Syncfusion update version 17.4.0.43 and Xamarin.Forms version 4.4.0.991
 
Please check the sample and let us know if you still facing the same issue? If not, please modify the sample based on your scenario and revert us back with the following details, 
 
·       Device configuration details 
·       Issue reproducing video (if possible) 
·       Syncfusion and Xamarin.Forms update version 
 
It will be helpful for us to check on it and provide you the solution at the earliest.   
 
Regards,
Karthik Raja A


Kalle Bumba
Replied On January 15, 2020 09:34 AM UTC

Hello,

thanks for your answer and the provided example.

My problem is solved. It was a mismatch between the resource id set in xaml (which is a string) and the resource id in the event (which is an int).

Regards,
  Kalle



Karthikraja Arumugam [Syncfusion]
Replied On January 15, 2020 11:16 AM UTC

Hi Kalle, 
 
Thank you for the update. 
 
Please get in touch with us if you would require further assistance. We are always happy to assist you. 
 
Regards, 
Karthik Raja A 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon