We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DatePicker only opens after 3 clicks

Thread ID:

Created:

Updated:

Platform:

Replies:

150541 Jan 10,2020 11:19 AM UTC Jan 15,2020 09:19 AM UTC Blazor 5
loading
Tags: DatePicker
Guðmundur
Asked On January 10, 2020 11:19 AM UTC

Hi, it seems that the datepicker only opens after I have given it 3 clicks. I even tried using the @onmousedown event and that does nothing for me.
I have added a focus event to open it upon focus which works fine with 1 click of the input box.

Code:
<EjsDatePicker TValue="DateTime?"
                       @ref="datepickerRef"
                       Placeholder='Velja dagsetningu'
                       Value='@DateValue'
                       Min='@MinDate'
                       Max='@MaxDate'
                       Format='dd.MM.yyyy'
                       @onmousedown="datepickerClicked">
            <DatePickerEvents TValue="DateTime?" ValueChange="@onChange" Focus="FocusHandler"></DatePickerEvents>
        </EjsDatePicker>

Sureshkumar P [Syncfusion]
Replied On January 13, 2020 11:09 AM UTC

Hi Guðmundur, 
 
Greetings from Syncfusion support. 
 
We have checked your requirement and unfortunately, we could not reproduce the reported issue at our end. So, we have prepared the sample based on the provided code example and attached it below. 
 
 
Still, the issue persists, please revert us with below details that will help us to check and proceed further.  
 
1.     Issue reproducing sample 
 
2.     Code block of the fired event for DatePicker component  
 
3.     Any other configuration details enabled in your application  
 
4.     Modify the provided sample with the reported issue 
 
Regards, 
Sureshkumar P 


Guðmundur
Replied On January 13, 2020 11:59 PM UTC

Hi again, thank you for great service and response time.

I have tried your sample and it works 100% as expected but it is for server and I forgot to mention I am using Blazor Client. When I take your code from Index.razor and put it in a new Client project with the bare minimum required for just the datepicker to work I get the same behaviour (needs 3 clicks).

Another thing I notice which I previously thought was because I have a lot going on in the real Client App is the datepicker (and probably other things also) is lagging a bit but in the Server App in your sample it works without hesitation. I just haven't tested Server Blazor before so I didn´t know.

I have included my Datepicker_test Client app so you can see what I mean. Maybe you see something fatal that I am missing :)


Thanks,
Guðmundur

Attachment: Datepicker_test_94581ad7.zip

Sureshkumar P [Syncfusion]
Replied On January 14, 2020 09:27 AM UTC

Hi Guðmundur, 
 
Greetings from Syncfusion support. 
 
We were able to replicate your reported problem in the DatePicker component. We have confirmed this as a bug at our end. We will fix and include the solution on our next week patch release, which is expected to be rolled out on January 21st, 2020. Please be patient until then. 
 
You can track the status of this problem by using the below feedback portal. 
 
 
Regards, 
Sureshkumar P 


Guðmundur
Replied On January 14, 2020 12:44 PM UTC

Thanks for that, no problem.

Glad to hear it´s on the right track.

Gopi Govindasamy [Syncfusion]
Replied On January 15, 2020 09:19 AM UTC

Hi Guðmundur, 

Most Welcome. Let you know, once resolved the issue.  

Regards, 
Gopi G. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon