We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Report designer web, export to rdl not work and report client designer for windows without option datasource api rest

Thread ID:

Created:

Updated:

Platform:

Replies:

150369 Jan 3,2020 02:07 PM UTC Jan 10,2020 10:00 AM UTC Report Platform 5
loading
Tags: Report Designer
Juan Camilo Cardona Graciano
Asked On January 3, 2020 02:07 PM UTC

Hello,  
recently try downloading a report from report designer web and the button is disabled, then download the client for windows design and find that it does not support the api rest data source option.I need to build a report from an api rest type datasource and then generate the rdl file

Attachment: screenshots_4d402f95.zip

Vinoth Srinivasan [Syncfusion]
Replied On January 6, 2020 06:14 AM UTC

Hi Juan, 

Thanks for your interest in BoldReports. 

We have restricted the download option in our demo server and for WebAPI datasource we need to add the extension. We will consider to included WebAPI datasource option in demo server for upcoming releases and as of now we suggest you install the On-Premise build to design the report based on your requirement. 

Regards, 
Vinoth S. 


Juan Camilo Cardona Graciano
Replied On January 7, 2020 03:42 PM UTC

Hello thank you for your response, could you please indicate the download path for " On-Premise build "

Vinoth Srinivasan [Syncfusion]
Replied On January 9, 2020 12:32 PM UTC

Hi Juan, 

For your requirement, we are recommending designing the report using Report Designer available in Embedded Reporting Tools Build Add On instead of using our demo server. You have to download Bold Reports Embedded Reporting Tools from our Bold Reports site using your Syncfusion registered account. 


 

As of now, we don’t have the WebAPI datasource as default option with ReportDesigner. So, we request you to download the additional files from below link and replace it below mentioned installed location to work with WebAPI data source. 
 
 
Location: $installed driver$\Program Files (x86)\ Bold Reports\Embedded Reporting Tools\Utilities\Report Designer 

Regards, 
Vinoth S. 


Juan Camilo Cardona Graciano
Replied On January 9, 2020 07:55 PM UTC

Hello, thank you for you response. I followed all the steps without success the application is loading and never ending.






Vinoth Srinivasan [Syncfusion]
Replied On January 10, 2020 10:00 AM UTC

Hi Juan, 

We have created the previously shared file compatible with our latest Bold Reports 2.1 SP release version 2.1.23 version which has been released on January 8, 2020. We suspect that you have replaced the shared files with 2.1.14 Bold Reports version and due to this the issue has been occurred. So, we suggest you upgrade to latest release and replace the file in mentioned location to resolve this issue. 

Regards, 
Vinoth S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon