We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

XP & Windows 2000

Thread ID:

Created:

Updated:

Platform:

Replies:

15022 Jun 9,2004 11:18 PM Jun 11,2004 06:54 AM Windows Forms 3
loading
Tags: Tools
Satish
Asked On June 9, 2004 11:18 PM

Hi Guru, I am having serious problems with using the controls like Tab, Treeview on different OS. Having these controls, run on XP will produce white background color and in win 2K, will produce gray background color. I would like to keep both consistent. How can I achieve this. Thanks Satish

Administrator [Syncfusion]
Replied On June 10, 2004 07:56 PM

Hi Satish, Have you turned on the ThemesEnabled property for the TreeViewAdv control ? Let me know about it. If so, this is the intended behavior when controls are drawn using themes. When themes are enabled, the drawing responsibility for the control is delegated to the OS, and it gets drawn with a themed style on an OS which supports themed drawing (like Windows XP). Hence it ignores all other custom drawing settings specified in the code. Please let me know if you need any other information. Regards, Guru Patwal Syncfusion, Inc.

Administrator [Syncfusion]
Replied On June 10, 2004 09:07 PM

Hi Guru, Thanks for your response. But my problem is that, i would to keep both XP & Windows look same. I mean the background color only. Is there any way I can implmenet this please! Thanks Satish >Hi Satish, > >Have you turned on the ThemesEnabled property for the TreeViewAdv control ? Let me know about it. If so, this is the intended behavior when controls are drawn using themes. When themes are enabled, the drawing responsibility for the control is delegated to the OS, and it gets drawn with a themed style on an OS which supports themed drawing (like Windows XP). Hence it ignores all other custom drawing settings specified in the code. Please let me know if you need any other information. > >Regards, >Guru Patwal >Syncfusion, Inc.

Administrator [Syncfusion]
Replied On June 11, 2004 06:54 AM

Hi Satish, Thanks for the update. Please refer to the screenshots attached. I have created a test sample and captured screenshots when themes are turned on/off on Windows 2000 or Windows XP machines. But I found that the default background color is the same in all cases. I have attached the test sample here (note that this is was created using Essential Suite v2.0.5.1). 1. Are you able to recreate this issue in my test sample ? If not, could you modify this sample to show the above problem and send it back to us so that we could take a look at it? 2. Are you trying to set a custom BackColor to the TreeViewAdv when ThemesEnabled is set to true ? 3. Let me know the version of Essential Suite that you are using. We appreciate your cooperation. Regards, Guru Patwal Syncfusion, Inc.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;