We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Export PDF Report in landscape mode

Thread ID:

Created:

Updated:

Platform:

Replies:

149633 Nov 22,2019 05:09 AM UTC Jan 13,2020 11:42 AM UTC ASP.NET MVC 8
loading
Tags: ReportViewer
Support Arcania
Asked On November 22, 2019 05:09 AM UTC

Hello, 


I am encountering an issue while exporting the PDF from the PdfViewer in Syncfusion. When the PDF is exported, the layout of the page breaks. However, one possible solution to alleviate this issue is to export the PDF in landscape mode. Could anyone please clarify or suggest which settings to add to allow the export of the PDF to landscape mode ?  Thank you. 

Best Regards.

Akshaya Arivoli [Syncfusion]
Replied On November 25, 2019 10:17 AM UTC

Hi Arcania, 

Thank you for contacting Syncfusion support. 

We are unable to get your requirement with the provided details, can you please confirm us whether you are facing issue while Printing/Downloading the landscape PDF document from the PDF Viewer. Also can you please more details about your requirement, use case scenario, error details if any , screen shots and the PDF document. These details will be helpful for us to investigate further and assist you better. 

However, we have created simple PDF Viewer sample and shared the same in the following link, 


PDF Viewer getting started UG link, 


Please try this and revert us with more details if you have any concerns. 

Regards, 
Akshaya 


Support Arcania
Replied On December 3, 2019 05:50 AM UTC

Hi Aksharay, 

I have the used the following codes to initialize the report viewer in syncfusion:

    $("#viewer").ejReportViewer({
                reportServiceUrl: "/api/ApiController/Report",
                reportPath: '~/App_Data/GroupingAggregate.rdlc',
                processingMode: ej.ReportViewer.ProcessingMode.Local,
                dataSources: [
                    {
                        value: @Html.Raw(Json.Encode(Model.UserList)),

                        name: "Sales"
                    }
                ],
            });

The output is as follows (See attached image). 

When I click the Export button from the toolbar, the PDF is downloaded. However, the content of the PDF is distorted (the table is spread over two pages instead on a single page - landscape mode). I want to the downloaded PDF to be in landscape mode directly. I have also adjusted the page setup by setting the Orientation to Landscape but no effect. Can you please help? 
                                                                                     


Vinoth Srinivasan [Syncfusion]
Replied On December 4, 2019 01:27 PM UTC

Hi Arcania,  

If your requirement is to export the report in Landscape mode, then you need to set the page orientation as “Landscape” at report design level from Report Properties. If you still face any issue, then share your RDLC report with us to validate the problem at our end. 

Regards, 
Vinoth S. 


Support Arcania
Replied On December 10, 2019 05:06 AM UTC

Hi Arcania,  

If your requirement is to export the report in Landscape mode, then you need to set the page orientation as “Landscape” at report design level from Report Properties. If you still face any issue, then share your RDLC report with us to validate the problem at our end. 

Regards, 
Vinoth S. 


Hello Vinoth, 

I tried to set the page orientation to Landscape, but the report still being exported to Portrait mode. The RDLC report that I have used can be found here
:  https://pastebin.com/v40xyRVj

Best Regards.

Vinoth Srinivasan [Syncfusion]
Replied On December 10, 2019 06:37 AM UTC

Hi Arcania, 

We have validated your shared report and in that the page orientation is specified as Portrait only, so we have modified the page orientation as Landscape and it has been exporting properly as PDF in Landscape. Please find the modified report from the below location. 


If you still face any issue, then please share the Syncfusion product version you are using with us for further validation. 

Regards, 
Vinoth S. 


Support Arcania
Replied On January 13, 2020 07:38 AM UTC

Dear Vinoth, 

My syncfusion product version is 16.4.0.52. The issue persists on this version.

Support Arcania
Replied On January 13, 2020 09:41 AM UTC

Hi Arcania, 

We have validated your shared report and in that the page orientation is specified as Portrait only, so we have modified the page orientation as Landscape and it has been exporting properly as PDF in Landscape. Please find the modified report from the below location. 


If you still face any issue, then please share the Syncfusion product version you are using with us for further validation. 

Regards, 
Vinoth S. 


Hello, 

Can you tell which settings you have changed in the rdlc file that you sent ? 

Best

Vinoth Srinivasan [Syncfusion]
Replied On January 13, 2020 11:42 AM UTC

Hi Arcania, 

We need to set the landscape for the report from page settings in design level using Visual studio. Please find the below steps for how to set the landscape at design level. 
Step 1: Open the RDLC report in Visual studio 
Step 2: Click the report outside and choose the report properties as shown in below snap. 

 
Step 3: Set landscape for report as shown in below snap. 
 
 
Also, we have validated this report with 16.4.0.52 version and it has been exporting properly. 
 
Regards, 
Vinoth S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon