We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Responsive DateRange

Thread ID:

Created:

Updated:

Platform:

Replies:

148487 Oct 22,2019 10:59 AM UTC Jan 17,2020 01:32 PM UTC Angular - EJ 2 6
loading
Tags: DateRangePicker
Ali Kholmatov
Asked On October 22, 2019 10:59 AM UTC

Hi! Could I fix it? I think there must be mobile version




Sureshkumar P [Syncfusion]
Replied On October 23, 2019 06:41 AM UTC

Hi Ali, 
 
Greetings from Syncfusion support. 
 
We have validated your requirement with screenshot. We have render the daterangepicker mobile popup based on size of the window width. If window width exceeds 550px then our popup opens as like desktop mode. That is the reason the popup was opened like desktop mode. 
 
Regards, 
Sureshkumar P 


Ali Kholmatov
Replied On October 25, 2019 09:05 AM UTC

Sorry , but how can I manage it? it's not right

Ali Kholmatov
Replied On October 25, 2019 09:06 AM UTC

Hi Ali, 
 
Greetings from Syncfusion support. 
 
We have validated your requirement with screenshot. We have render the daterangepicker mobile popup based on size of the window width. If window width exceeds 550px then our popup opens as like desktop mode. That is the reason the popup was opened like desktop mode. 
 
Regards, 
Sureshkumar P 


Sorry , but how can I manage it? it's not right

Berly Christopher [Syncfusion]
Replied On October 28, 2019 12:42 PM UTC

Hi Ali, 
 
Thanks for you update. 


We have checked your query and would like to inform you that if the width of window exceeds 550px, then calendar of daterangepicker will be rendered for Desktop mode. If you want to change toggle it to mobile mode, you can change the variable isMobile  into true in Created event. We have made sample for your convenience. Please find the sample below.

 
  
Please refer the below KB for further information.

KB Link: https://www.syncfusion.com/kb/10327/how-to-render-daterangepicker-with-single-calendar

 
  
Regards, 
Berly B.C 


Jinu
Replied On January 15, 2020 04:08 PM UTC

Hi,

DateRange picker is  not responsive .Its exceeding the screen limit even if 411 pixel width.

Please see the image



Prince Oliver [Syncfusion]
Replied On January 17, 2020 01:32 PM UTC

Hi Jinu, 

Thank you for contacting Syncfusion support. 

To make the DatePicker component response, kindly enable the mobile mode by setting the isMobile  into true in Created event. Kindly refer to the following example 

If you have rendered the control in the desktop mode, to enable mobile mode in the smaller width, you need to refresh the component. If this does not meet your requirement. Kindly share us additional information on your requirement. This will help us provide a prompt solution. 

Regards, 
Prince   


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon