We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

syncfusion BoldBi Report Server Installation Issue : Specified key was too long; max key length is 3072

Thread ID:

Created:

Updated:

Platform:

Replies:

148042 Oct 2,2019 09:25 PM UTC Oct 8,2019 01:19 PM UTC Report Platform 2
loading
Tags: Report Server
serhat alpaslan
Asked On October 2, 2019 09:25 PM UTC

syncfusion BoldBi Report Server Installation Issue 


I get this error during installation and cannot install.

mysql
innodb version : 8.0.15
version 8.0.15
Specified key was too long; max key length is 3072 


Vinoth Srinivasan [Syncfusion]
Replied On October 4, 2019 01:59 PM UTC

Hi Serhat, 

We are validating the reported problem at our end and update you with details by 7th October 2019. 

Regards, 
Vinoth S. 


Mahendran Shanmugam [Syncfusion]
Replied On October 8, 2019 01:19 PM UTC

Hi Serhat Alpaslan,  

Thanks for your patience.  

We suspect the issue could be due to database query executed in the particular version of MySQL. So, we need some additional information about the query in which the execution failed. To trace this failure, enable advanced logs in Bold Report Server application. Please follow below steps to enable the advanced logs in Bold Report Server application,  

1. Stop the Bold Reports in IIS Express/IIS using Desktop shortcut. 
2. Please change “IsLogOptionalData” data value to true in the Web.config files present in the below location, 
                  
                  “C:\Bold Reports\Report Server\ReportServer.Web\API\Web.config”  
                   “C:\Bold Reports\Report Server\ReportServer.Web\Web.config”  


 
3. Save the file. 
4. Start the Bold Reports in IIS Express/IIS using Desktop shortcut. 
5. Please send us the logs from the below location, 
               “C:\Bold Reports\Report Server\ReportServer.Web\App_Data”  
  
This will be helpful to track the issue and provide better solution earlier.  

Regards,  
Mahendran S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon