We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon
If you became a customer of the Syncfusion Reporting Platform or the Report Viewer, Report Designer, or Report Writer components before October 2019 and have questions related to those products, you can request support through our forum system. However, please note that this support system is only for existing customers who are still using the Syncfusion Reporting Platform or its components and not for new customers looking for reporting products from Syncfusion.

For new customers or those with general reporting questions, we recommend contacting our support team at https://support.boldreports.com/, which is a separate brand created by Syncfusion for its reporting solutions. Our team will be happy to assist you with any questions you may have.

Thank you for choosing Syncfusion for your reporting needs.

syncfusion BoldBi Report Server Installation Issue : Specified key was too long; max key length is 3072

syncfusion BoldBi Report Server Installation Issue 


I get this error during installation and cannot install.

mysql
innodb version : 8.0.15
version 8.0.15
Specified key was too long; max key length is 3072 


2 Replies

VS Vinoth Srinivasan Syncfusion Team October 4, 2019 01:59 PM UTC

Hi Serhat, 

We are validating the reported problem at our end and update you with details by 7th October 2019. 

Regards, 
Vinoth S. 



MS Mahendran Shanmugam Syncfusion Team October 8, 2019 01:19 PM UTC

Hi Serhat Alpaslan,  

Thanks for your patience.  

We suspect the issue could be due to database query executed in the particular version of MySQL. So, we need some additional information about the query in which the execution failed. To trace this failure, enable advanced logs in Bold Report Server application. Please follow below steps to enable the advanced logs in Bold Report Server application,  

1. Stop the Bold Reports in IIS Express/IIS using Desktop shortcut. 
2. Please change “IsLogOptionalData” data value to true in the Web.config files present in the below location, 
                  
                  “C:\Bold Reports\Report Server\ReportServer.Web\API\Web.config”  
                   “C:\Bold Reports\Report Server\ReportServer.Web\Web.config”  


 
3. Save the file. 
4. Start the Bold Reports in IIS Express/IIS using Desktop shortcut. 
5. Please send us the logs from the below location, 
               “C:\Bold Reports\Report Server\ReportServer.Web\App_Data”  
  
This will be helpful to track the issue and provide better solution earlier.  

Regards,  
Mahendran S. 


Loader.
Live Chat Icon For mobile
Up arrow icon