We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DateTime column does not accept formatting/loses formatting after editing values

Thread ID:

Created:

Updated:

Platform:

Replies:

147576 Sep 17,2019 06:59 AM UTC Sep 18,2019 01:00 PM UTC WinForms 1
loading
Tags: SfDataGrid
Bill
Asked On September 17, 2019 06:59 AM UTC

I have two DateTime columns/cells on an SfDataGrid, one of which is supposed to display the date and another the time off the same SQL date field. However, setting the Format property on the second cell (the time cell) seems to be of no use, as the date (just the date,not the full date/time value) is still displayed when loading the data. 

I have tried adapting my SQL query to separate the values in case there's no other way to achieve this, but no matter how the Format property is set (tried both ShortTime and Custom formats), when I edit a value, the cell loses the formatting, reverting back to the full date/time format. Is there a property  I need to define for that?

Gowtham Gopalsamy [Syncfusion]
Replied On September 18, 2019 01:00 PM UTC

Hi Bill, 

We have analyzed your query to display the date in one column and time in another column when load the data format is displayed and when enter to edit the time column cell value format shows with corresponding format. We have attached the sample and still you are facing the issue .Please provide the sample or video about this query and the version of dashboard . It will help us to the further investigation for provide the earlier prompt solution.  

Please refer the sample link in below, 


Please refer the below video link, 


Regards, 

Gowtham 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon