We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Sorting in DataGrid does not work

Thread ID:

Created:

Updated:

Platform:

Replies:

1468 Nov 1,2002 06:48 AM UTC Nov 8,2003 08:52 PM UTC WinForms 2
loading
Tags: FAQ
Heike Brackmann
Asked On November 1, 2002 06:48 AM UTC

Using FAQ 5.21 (How can I have a column of icons in my datagrid?) I developed a form with a datagrid in it. AllowSorting is set to TRUE but there is no sorting, though an arrow in the header looks like there is. Any ideas that might help?

Administrator [Syncfusion]
Replied On November 21, 2002 10:33 PM UTC

If your datagrid is bound to an arraylist then you will have to custom sort your item. If the datagrid is bound to a datatable then sorting is done automatically. > Using FAQ 5.21 (How can I have a column of icons in my datagrid?) I developed a form with a datagrid in it. AllowSorting is set to TRUE but there is no sorting, though an arrow in the header looks like there is. Any ideas that might help?

Administrator [Syncfusion]
Replied On November 8, 2003 08:52 PM UTC

if you mean paging - turn off custom paging - then arrows for paging will become links > If your datagrid is bound to an arraylist then you will have to custom sort your item. If the datagrid is bound to a datatable then sorting is done automatically. > > > Using FAQ 5.21 (How can I have a column of icons in my datagrid?) I developed a form with a datagrid in it. AllowSorting is set to TRUE but there is no sorting, though an arrow in the header looks like there is. Any ideas that might help?

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;