We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Azure AD embedded reports always throwing error

Thread ID:

Created:

Updated:

Platform:

Replies:

145862 Jul 11,2019 04:51 AM UTC Jul 16,2019 01:09 PM UTC Report Platform 3
loading
Tags: Report Viewer
Hayden Harrison
Asked On July 11, 2019 04:51 AM UTC

I'm trying to view my reports embedded in a web app using azure AD auth (Passing it through an iframe).  I've setup my azure active directory as per the guides and I can successfully auth my azure user into the report server however I am always hit with an error of  "Value cannot be null. Parameter name: source" when viewing the report. The url I'm trying to access the report on ends in "?hascomments=false&hasviews=false&hassso=true&externallogin=azuread&loginstatus=success".  My datasource is connected to a SQL database.  I've tried simplifying my dataset to a simple query with no luck.  I've also tried adding a parameter called source to my report which changes my error to "Unhandled exception has occurred during data set 'DataSet1' processing."  

Let me know if you need anymore details.  Any help is greatly appreciated.

Vinoth Srinivasan [Syncfusion]
Replied On July 12, 2019 11:10 AM UTC

Hi Hayden, 
 
Thanks for your interest in Syncfusion Components. 
 
We suspect that the issue occurs when the users don’t have permission for accessing the shared datasource and shared dataset. So, we suggest you provide permissions for the user to access the shared datasource and shared dataset and please find the below help documentation for this. 
 
 
Also, could you please confirm whether the report has been rendering properly while running from ReportServer. 
 
Regards, 
Vinoth S. 


Hayden Harrison
Replied On July 14, 2019 08:36 PM UTC

Hi Vinoth,

Thanks for your reply.

I have tried using a shared datasource and dataset that I definitely have permission on and I get the error Unhandled exception has occurred during data set 'Test Auth Shared Dataset' processing. Bear in mind my azure user has been added to the Administrators group and I've double checked I have security on the Dataset and Datasource.

What I have working now is if I make a report that only has an internal Datasource and Dataset then go to the embedded Azure AD link (https://myreportserver/en-us/reports/embed/reports/MyReportName?hascomments=false&hasviews=false&hassso=true&externallogin=azureAd) and then auth with azure AD I can auth successfully but get the same error as before "Value cannot be null. Parameter name: source" .

However if I remove the "&externallogin=azureAd" from the url after I've been authenticated I can successfully view the report.  This seems like a bug to me.  It seems like azure ad isn't working with shared datasources/datasets and also that "&externallogin=azureAd" parameter seems to cause problems once the user has been authenticated.  Do you have an environment with azure ad setup to test this scenario to check whether this is some problem with how I've configured everything or just a bug with the report server?


As a side note from the user management page clicking on an Azure AD imported user gives me an error page saying "Internal Server Error", not sure if this is related.

Cheers
  

Vinoth Srinivasan [Syncfusion]
Replied On July 16, 2019 01:09 PM UTC

Hi Hayden, 

A support incident has been created under your account and we request you to login into our Direct Trac support system for further updates on this issue. Our Direct Trac support system can be accessed from the following link: 
 
Regards, 
Vinoth S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon