We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

The problem with Layout Type.

Thread ID:

Created:

Updated:

Platform:

Replies:

145270 Jun 14,2019 10:16 AM UTC Jul 17,2019 05:23 AM UTC WPF 5
loading
Tags: SfRichTextBoxAdv
Kuldeep
Asked On June 14, 2019 10:16 AM UTC

Whenever I try to set LayoutType to Contineous or Pages it works, but as soon I set it to Block it throws an error "Object reference not set to an instance of an object". Please solve my issue asap. 
This is my code.

<sf:SfRichTextBoxAdv x:Name="RichBox" x:FieldModifier="public" Grid.Row="1" BorderBrush="#AFAFAF" BorderThickness="1" IsZoomEnabled="False" FontSize="14" FontFamily="Global User Interface" LayoutType="Block" Height="400" AllowDrop="True"/>

Ramya Thirugnanam [Syncfusion]
Replied On June 18, 2019 11:37 AM UTC

Hi Kuldeep, 
 
Thanks for contacting Syncfusion support. 
 
We were unable to replicate the reported issue with LayoutType as Block. It works properly without exception. We have tried using Syncfusion assemblies of v17.1.0.38 version. We have provided the sample to represent this. Please refer to the sample from the below link. 
  
 
Could you please shared the modified sample and video to reproduce the issue? So that we can analyze further and provide appropriate solution at the earliest. 
 
Regards, 
Ramya T 


Kuldeep
Replied On June 21, 2019 07:11 PM UTC

I got the problem, it was the Skin Manager who was causing the problem, deleting the line fixed it.
I used this to make my window metro styled but it seems that it has problems with other controls.
Please fix this bug.

sfskin:SfSkinManager.VisualStyle="Metro"



Ramya Thirugnanam [Syncfusion]
Replied On June 24, 2019 12:30 PM UTC

Hi Kuldeep, 
We can reproduce the reported issue. We are validating the reported issue and we will get back to you with further details on June 26th, 2019. 
Regards, 
Ramya T 


Ramya Thirugnanam [Syncfusion]
Replied On June 26, 2019 02:27 PM UTC

Hi Kuldeep, 
 
We will fix the issue and include this fix in our Volume 2 main release on mid of July 2019. We will get back to you once Volume 2 release is rolled out. 
 
The reported issue can be tracked through the below feedback link: 
 
 
Could you please confirm us whether need patch for this issue earlier? So that, we can share the patch for the reported issue based on your confirmation. 
 
Regards, 
Ramya T 


Ramya Thirugnanam [Syncfusion]
Replied On July 17, 2019 05:23 AM UTC

Hi Kuldeep,  
 
We are glad to announce that our Essential Studio 2019 Volume 2  release v17.2.0.34  is rolled out and is available for download under the following link. We have included the fix for the reported issue in this release. 
 
 
Regards, 
Ramya T 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon