We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

sfchart legend hides after a navigation!

Thread ID:

Created:

Updated:

Platform:

Replies:

144135 Apr 21,2019 02:57 PM UTC Apr 23,2019 06:52 AM UTC Xamarin.Forms 3
loading
Tags: SfChart
Reihaneh Khaksaran
Asked On April 21, 2019 02:57 PM UTC

Hello,

I've got a weird problem, I have a chart in my app that has legend and series, but the chart isn't located in my main page, I have to navigate to another page to see my chart, the first time that I navigate to the page in which my chart is located everything works fine, but the problem is that when I navigate back to the main page and go back to the chart page again, then the legend just becomes invisible and the series won't work either!
I have created a sample based on the behavior on my app that reproduces the same issue, I'd appreciate if you could take a look at it and help me resolve the issue, in the sample there is a button which takes you to the chart page and in the chart page there is another button that takes you back to the main page, so if you go back to the chart page again, you see what my problem is. Thank you so much in advance, oh, and by the way I have this problem on the Android part of the project, I haven't tested on ios yet, but I just need this to work on Android for now.

Best Regards,
Reihaneh

Attachment: ChartTest_3c3893c6.zip

Devakumar Dhanapoosanam [Syncfusion]
Replied On April 22, 2019 10:46 AM UTC

Hi Reihaneh, 
 
Greetings from Syncfusion. 
 
We have analyzed your query and the sample provided. The reported issue occurs in the 16.4.0.40 beta version and while checking this issue with latest it has been resolved from the 16.4.0.42 version. Please update the SfChart version to 16.4.0.42 or the latest and let us know whether the issue has been resolved at your end. 
 
Please let us know if you need any further assistance. 
 
Regards, 
Devakumar 


Reihaneh Khaksaran
Replied On April 23, 2019 06:32 AM UTC

Hi,

Thanks you so much, updating resolved the issue

Best Regards,
Reihaneh

Bharathiraja K [Syncfusion]
Replied On April 23, 2019 06:52 AM UTC

Hi Reihaneh,  
 
We are glad that the reported problem resolved at your end. 
 
-Bharathi. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon