We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Make combo box not editable and hide keyboard

Thread ID:

Created:

Updated:

Platform:

Replies:

143867 Apr 8,2019 02:22 PM UTC Apr 11,2019 05:54 AM UTC Xamarin.Forms 3
loading
Tags: SfComboBox
Jiri Matejka
Asked On April 8, 2019 02:22 PM UTC

Hello,

am using SfComboBox to provide a control to select one or more items from a list, but not to allow to enter a free text value. 

Am using following XAML code to render the control:
<sfcom:SfComboBox x:Name="cmbLabels"                                                            
                                  IsEditableMode="False"
                                  TokensWrapMode="None"
                                  IsSelectedItemsVisibleInDropDown="false"
                                  MultiSelectMode="Token">
                        <sfcom:SfComboBox.TokenSettings>
                            <sfcom:TokenSettings FontSize="15" 
                                            BackgroundColor="#66ccff" 
                                            TextColor="White" 
                                            SelectedBackgroundColor="#ffffe0" 
                                            DeleteButtonColor="Navy"                                          
                                            IsCloseButtonVisible="true" 
                                            CornerRadius="10">
                            </sfcom:TokenSettings>
                        </sfcom:SfComboBox.TokenSettings>
                    </sfcom:SfComboBox>

I have three issues with this:
1. Although IsEditableMode is set to false (which is also default) the SfCombo allows to enter a free text item. Any way how to disable free text editing?

2. When I tap to the Combo it displays the list (which is OK) but also shows the virtual keyboard (which is not OK) and the keyboard overlaps the list of options. Is there a way how to supress the keyboard? See the example below - "Altoona" is the first option, then there are four more options that are hidden by the keyboard. 





Any ideas?

thanks

Jiri


Muneesh Kumar G [Syncfusion]
Replied On April 9, 2019 07:33 AM UTC

Hi Jiri, 
 
Greetings from Syncfusion, we have checked the reported problem in SfComboBox Control and unfortunately, we could not able to reproduce the same from our side.  
 
We have prepared a sample with MultiSelect Mode set as Token and IsEditableMode as False and it is working as expected. Please have the sample from the below link, 
 
 
Screenshot :  
 
 
 
Please check with the sample and if the issue still persists please modify the sample and provide us the device with which the issue is reproduced which will be helpful for us to analyze further and provide an appropriate solution. 
 
Thanks, 
Muneesh Kumar G. 


Jiri Matejka
Replied On April 9, 2019 09:19 PM UTC

Thanks for the example,  I appreciate that. 

Seems to be resolved by upgrading to 17.1.0.40 build (the same as in your example). I was on 16.* (roughly two month ago build). 

Thanks for your help!

Jiri

Muneesh Kumar G [Syncfusion]
Replied On April 11, 2019 05:54 AM UTC

Hi Jiri, 
 
We are glad to know that the given solution works. Please let us know if you need any further assistance. 
             
Thanks, 
Muneesh Kumar G. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon