We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Custom Month Cell: Always some space at the bottom of the cell

Thread ID:

Created:

Updated:

Platform:

Replies:

143565 Mar 26,2019 09:02 PM UTC May 20,2019 12:09 PM UTC Xamarin.Forms 8
loading
Tags: SfSchedule
bkind
Asked On March 26, 2019 09:02 PM UTC

Hi,

since AppointmentDisplayMode will not be applied on Android platform I have a custom month cell. It displays a label per appointment, arranged e. g. within a StackLayout or Grid. I use ViewLayoutOptions.Overlay because I want to keep the style given by the schedule, I just want the labels to be shown, not the appointment indicators.

The problem is that there is always some space between the labels and the bottom of the cell, so that the indicators are visible. When I use a frame as custom view it fills the whole cell. So does a grid, a stacklayout or whatever. But every control within this "top level" view does not "reach" the bottom of the cell. Just as if there were a bottom padding which cannot be undone or overwritten. I have included a sample project as well as a screenshot showing 5 month cells, the 4th and the 5th having a boxview within a frame as custom month cell. One can see the gap between the bottom of the boxview and the bottom of the cell. The 5th cell also shows that the frame fills the cell (as it does in the 4th cell, but with transparent background color).

I cannot find a way to have the labels (or any other "inner" control of a custom cell view) fill the cell down to the bottom. Is there?

Btw: Using XF 3.4 and Sf 16.4.0.52

Kind regards

bkind
Replied On March 26, 2019 09:07 PM UTC

Hi again,

sorry, forgot to upload. Here it is.

Kind regards

Attachment: SfSchedule.Test_67387d7c.zip

Subburaj Pandian Veluchamy [Syncfusion]
Replied On March 27, 2019 02:01 PM UTC

Hi B Kind, 
  
Thank you for contacting Syncfusion support. 
  
We are analyzing the reported behavior “Month view custom view doesn’t occupy the full month cell area in schedule month view while using complex layout”. We will validate and let you know the details in two business days (March 29, 2019). We appreciate your patience until then. 
 
Regards,
Subburaj Pandian V  
 


Subburaj Pandian Veluchamy [Syncfusion]
Replied On March 29, 2019 05:33 AM UTC

Hi B Kind, 
  
Thank you for your patience. 
  
We can reproduce the reported issue “Month view custom view doesn’t occupy the full month cell area in schedule month view while using complex layout” and we have logged an issue report for the same. We will update you with patch for this issue fix by April 22, 2019. We appreciate your patience until then.  
 
You can now track the status of this request and contact us for any further inquiries through this link. 
  
  
Regards,
Subburaj Pandian V 


Subburaj Pandian Veluchamy [Syncfusion]
Replied On April 22, 2019 01:01 PM UTC

Hi BKind, 
  
Thank you for your patience. 
  
We have fixed the reported issue “Month view custom view doesn’t occupy the full month cell area in schedule month view while using complex layout” and the patch for the issue fix is following. 
  
Set Up: 
  
Custom Assemblies: 
  
Nuget: 
  
Kindly find the below link to clear Nuget cache,
https://www.syncfusion.com/kb/6987/how-to-clear-nuget-cache   
 
    
Installation Direction:       
{Syncfusion Installed location}\Essential Studio\17.1.0.38\Xamarin\lib\pcl\Syncfusion.SfSchedle.XForms.dll             
{Syncfusion Installed location}\Essential Studio\17.1.0.38\Xamarin\lib\android\Syncfusion.SfSchedule.XForms.Android.dll             
     
Disclaimer:     
Please note that we have created this patch for version 17.1.0.38 specifically to include the issue reported in the Forum 143565, this fix will be included in our upcoming Volume 1 SP 1 release which is expected to roll out at the mid of March 2019. 
    
Please let us know if you need further assistance.    
 
Regards,
Subburaj Pandian V  
 


bkind
Replied On April 26, 2019 08:56 PM UTC

Hi,

thank you for the path, I'll check it as soon as possible.

Kind regards

Jagadeesan Pichaimuthu [Syncfusion]
Replied On April 29, 2019 06:41 AM UTC

Hi BKind, 

Thanks for the update. 

We will wait to hear from you. 

Regards, 
Jagadeesan 


bkind
Replied On May 17, 2019 08:41 PM UTC

Hi,

I tested the patch with the sample solution I uploaded and I can say that the patch works. Thank you very much.

The only thing I'm wondering: If I use a frame as customcellview - why shows setting a top margin on the frame no effect at all? The frame in the picture (Thu, violet background, vertical and horizontal options: fill, padding: 0, margin: 10) just ignores any margin I set.
It's not critical however. But if you want the date numbers remain visible you have to use an extra frame with padding as a transparent container for the real content, which would not be neccessary if setting margin did work.
This is just for information.

Thanks again for the patch.

Kind regards


Subburaj Pandian Veluchamy [Syncfusion]
Replied On May 20, 2019 12:09 PM UTC

Hi BKind, 
 
Thank you for the update. 
 
We have analyzed your query "Margin for CustomCellView has no effect" based on your sample. In your sample, you are trying to set margin for frame but there is no parent for frame, your requirement can be achieved by using frame inside a parent view (Grid/Stack). 
 
We have modified your sample, 
  
  
We hope that this helps. Kindly revert us if you have any concern. 
 
Regards,
Subburaj Pandian V    


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon