We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Grouping Functionality Stopped Working

Thread ID:

Created:

Updated:

Platform:

Replies:

142475 Feb 5,2019 07:13 PM UTC Feb 7,2019 06:12 AM UTC ASP.NET Web Forms 2
loading
Tags: Grid
Mike Potratz
Asked On February 5, 2019 07:13 PM UTC

I have an application which has been in place for almost a year but needed significant changes to a particular report.  Using TFS, I branched the project to preserve the original.  Once it was branched I updated the project from Syncfusion 15.2460.0.40 (web.config value) to 16.3460.0.17.

Once I had done that I opened the page I needed to modify to test.  On this page I have a grid where I have grouping enabled and a default grouped column.  When running the page the query would run and the grid would show 254 (for example) rows of data.  But the grid was collapsed and didn't show any rows.  Also the default grouping column was not displayed on top.  I tried dragging a column up to the group bar but nothing would happen.

I deleted the default grouping column and then when running it, all of the datarows were displayed.  But I still could not drag and drop and column up to the group bar.  I'd drag it up, the grouping bar would expand and I'd see the "ghost" column header there.  But as soon as I released it, the column header would disappear the the grouping bar would shrink back down.

So I went back to the original project (v. 15.2460.0.40) and that same page worked just fine.

Been beating my head on the wall for 2 days now trying to figure this out with no luck. Has anyone else run into this?

Vignesh Natarajan [Syncfusion]
Replied On February 6, 2019 07:27 AM UTC

Hi Mike, 

Thanks for contacting Syncfusion Support. 

Query: “Grouping Functionality Stopped Working” 

From your query, we understand that you are facing issue with grouping in ejGrid. We have analyzed the reported issue and prepared sample on 15.2.0.40 and later changed into 16.3.0.17 with default Grouping enabled but we are unable to reproduce your reported problem at our end.  

Refer to the Sample Link:-  


We need some additional information to find the cause of the issue. Please share us the following details. 

  1. Complete Grid code example(both in server and client side)
  2. Script Error from the console window(if any).
  3. Screenshot/Video Demo to replicate the issue.
  4. If possible replicate the issue in the above sample and revert us back.

Regards, 
Vignesh Natarajan. 


Gangabharathy Murugasen [Syncfusion]
Replied On February 7, 2019 06:12 AM UTC

Good Morning, 

Thanks for the quick reply.  

When putting together all of the items you requested, I decided to get a file diff viewer to compare all of the files.  In working through all of the files I discovered that when upgrading from 15.2460.0.40 to 16.3460.0.17 it did NOT add Syncfusion.core.dll to the project references.  NOTE: When I updated the project I used this function within Visual Studio (VS2015 Pro) and followed all the on-screen prompts. 
 
 

I added the Syncfusion.core.dll to the updated project and the grid grouping function worked again. 

I have not tried upgrading any other projects as of yet to verify if this was just a ‘one-off’ issue or if it happens every time.  May be something for you to check out. 

Again, thank you for responding so quickly to my issue! 

Mike 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon