We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

How to make covered cells text always visible

Hi, We have both scalar (singular value) and array data for the rows in our grid. For the scalar data, we would like the value to be displayed (visible) anywhere in the row. I tried the covered range, with horizontal alignment = center but if this is a wide grid (say 100 columns) you can not always see the text or value in the covered range. Is there an easy way to make it always visible? thanks, Corinne

9 Replies

AD Administrator Syncfusion Team April 29, 2004 03:59 AM

You can try to do this using dynamic covered cells using the QueryCoveredrange event. Attached is a sample. One problem is a flicker that occurs when you scroll the grid 1 column at a time. By default, the grid calls WindowScroll and then just repaints the newly exposed column. This will cause a flicker in this dynamic covered cell situation. The sample has the flicker problem. If you turn off the support for WindowScroll, this will force the grid to repaint all cells with each scroll, but it will avoid the flicker. You can do this by adding this line to the form''s constructor. this.gridControl1.DisableScrollWindow = true; 10790_8649.zip


CM Corinne Muir April 29, 2004 07:31 AM

Thanks - that works great - only one small point - when I resize it smaller it doesn''t display the text until I drag the scroll bar a little - what event should I catch to force the redraw? Corinne


CM Corinne Muir April 30, 2004 02:22 PM

Hi Clay, any ideas on making this sample app have the text always visible even when its shrunk? >Thanks - that works great - only one small point - when I resize it smaller it doesn''t display the text until I drag the scroll bar a little - what event should I catch to force the redraw? > >Corinne


AD Administrator Syncfusion Team April 30, 2004 04:41 PM

Try setting this property: this.gridControl1.SmoothControlResize = false;


CM Corinne Muir May 3, 2004 08:20 AM

Super! Thanks - that works :) >Try setting this property: > >this.gridControl1.SmoothControlResize = false; >


CM Corinne Muir May 7, 2004 08:18 AM

One other issue is when we try to change the text - we cannot see it until we hit enter. What would you recommend as the best way to handle entering in text for a covered range? thanks, Corinne


AD Administrator Syncfusion Team May 7, 2004 05:59 PM

In DrawCell, add a check for the current cell not being edited. if(e.RowIndex == 2 && e.ColIndex == this.gridControl1.LeftColIndex && !this.gridControl1.CurrentCell.IsEditing) { //..... }


CM Corinne Muir May 12, 2004 07:56 AM

Thanks Clay - that works for text. We still have one more issue - for some of these covered ranges - they are dates or booleans - so when we edit them we want the dropdown calendar, or the boolean checks. How can we enable that? thanks again! Corinne


CM Corinne Muir May 12, 2004 09:59 AM

Just a further note - the date calendar popup is visible if I make my grid small - its just not visible if there are more columns than can be displayed in one screen. The boolean checkbox cell type doesn''t display at all even if the grid is totally visible. >Thanks Clay - that works for text. > >We still have one more issue - for some of these covered ranges - they are dates or booleans - so when we edit them we want the dropdown calendar, or the boolean checks. How can we enable that? > >thanks again! > >Corinne

Loader.
Live Chat Icon For mobile
Up arrow icon