We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Double characters when autocomplete is empty

Thread ID:

Created:

Updated:

Platform:

Replies:

132681 Sep 15,2017 02:22 AM Sep 27,2017 08:37 AM Xamarin.Forms 3
loading
Tags: SfAutoComplete
Espen Evje
Asked On September 15, 2017 02:25 AM

Hi,
I am using the SfAutoComplete in a Xamarin.Forms project, but have some weird behaviour happening the very first time I type a character in the field.

Two characters of the same letter is shown in the autocomplete box and I have to remove one of them to continue, otherwise the double character remain at the start of the search string and the autocomplete will not kick in because there are no words beginning with double letters.

After removing the second character, the autocomplete kicks in and the control works as normal. Even if I remove both of the characters and start typing the same character again, all works fine.

The double character happens again if I use the x at the right of the control to empty the control. The next character I type adds a second character to the search string. Seems to happen no matter what kind of settings I use for the control and for all letters.

Can someone please tell me if this can be avoided or make a fix if it is a bug?

I am using the version 15.3.0.29 of the SfAutoComplete control on an iOS device. Have not tried Android.

/espen

Selva Kumar  Veerakrishnan [Syncfusion]
Replied On September 18, 2017 08:18 AM

Hi Espen,

Thank you for Contacting Syncfusion Support.

A support incident to track the status of this defect has been created under your account.

Please log on to our support website to check for further updates.

Link: https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents/  

Regards,
Selva Kumar V.

Gary
Replied On September 26, 2017 06:42 PM

I'm also seeing this behaviour on iOS using SfAutoComplete v15.3.0.29



Selva Kumar  Veerakrishnan [Syncfusion]
Replied On September 27, 2017 08:37 AM

Hi Gary,

Thank you for contacting Syncfusion Support.

We have fixed the issue "Double character gets entered on SfAutoComplete when we type a single character". This fix will be included in our Volume 3 Service pack 2 which is expected to be rolledout by the end of September 2017.

Regards,
Selva Kumar V.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;