We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Disable scroll bar

Thread ID:

Created:

Updated:

Platform:

Replies:

131689 Jul 23,2017 06:48 PM Jul 25,2017 08:24 AM ASP.NET Core 3
loading
Tags: Schedule
Victor
Asked On July 23, 2017 06:48 PM

I need help with the schedule, I am trying to disable the scroll bar and it does not work for me

Sellakumar [Syncfusion]
Replied On July 24, 2017 08:59 AM

Hi Victor, 

Thanks for contacting Syncfusion support. 

In schedule the scrollbar renders by default. In order to prevent this scrollbar, the value of height property of the schedule should not be define. The schedule renders with default height, now the scrollbar does not render. Kindly check this solution in your project and revert us, if you need any further assistance on this. 

Regards, 
Sellakumar K

Victor
Replied On July 24, 2017 10:32 AM

Thanks for the help, in my project I don't define height property and anyway the scrollbar continue rendering. The schedule is defined as follows:

Html.EJ().Schedule("Schedule")
        .AppointmentTemplateId("#apptemplate")
        .ShowQuickWindow(false)
        .CurrentDate(DateTime.Now)
        .ShowAllDayRow(false)      
        .IsResponsive(true)       
        .ContextMenuSettings(cm => cm.Enable(true)
            .MenuItems(m => m.Cells(cellsItems)))
        .CategorizeSettings(field => field.Datasource(CategorizeValue)
            .Enable(true)
            .Id("Id").Text("Text").Color("Color").FontColor("FontColor"))
        .AppointmentSettings(fields => fields.Datasource(scheduleDataSource)
            .Id("Id")
            .Subject("Subject")
            .Description("Description")
            .StartTime("StartTime")
            .EndTime("EndTime")
            .AllDay("AllDay")
            .Recurrence("Recurrence")
            .RecurrenceRule("RecurrenceRule")
            .Categorize("Categorize"))
        .ScheduleClientSideEvents(e => e.ResizeStop("onResizeStop"))
        .ScheduleClientSideEvents(e => e.DragStop("onDragStop"))
        .ScheduleClientSideEvents(e => e.Navigation("onNavigation"))
        .ScheduleClientSideEvents(e => e.MenuItemClick("onMenuItem"))
        .ScheduleClientSideEvents(e => e.CellDoubleClick("onDoubleClick"))       
        .Render();



Karthigeyan Krishnamurthi [Syncfusion]
Replied On July 25, 2017 08:24 AM

Hi Victor        
     
Thanks for your update. 
We have prepared the Core sample to render the Schedule in full height without scroller which can be download from the below location.  
 
Kindly try the sample and if the issue persists, try to reproduce the error in a sample and revert it back to us. Or else you can share your index page code example/runnable sample (if possible) to proceed further.   
 
Regards, 
Karthigeyan 




CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;