We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

AOT build with bootstrap-theme

Thread ID:

Created:

Updated:

Platform:

Replies:

131566 Jul 16,2017 10:46 AM UTC Aug 8,2017 10:27 AM UTC JavaScript 4
loading
Tags: General
Marko
Asked On July 16, 2017 10:46 AM UTC

Hi,

until now I have using material theme at my Angular2 project and everything worked well (even AOT build with Angular CLI). Then I have only changed css source from ej/web/material/ej.web.all.min.css to ej/web/bootstrap-theme/ej.web.all.min.css and now I get the following errors:

[31mERROR in ./~/css-loader?{"sourceMap":false,"importLoaders":1}!./~/postcss-loader?{"ident":"postcss"}!./~/syncfusion-javascript/Content/ej/web/bootstrap-theme/ej.theme.min.css
Module build failed: Missed semicolon (9:216745)

@ ./~/syncfusion-javascript/Content/ej/web/bootstrap-theme/ej.web.all.min.css 4:10-134
@ multi ./src/scripts/style.css ./src/scripts/skins.css ./src/scripts/mantoStyle.css ./src/scripts/dhtmlxgantt.css ./~/bootstrap/dist/css/bootstrap.min.css ./~/font-awesome/css/font-awesome.css ./~/devextreme/dist/css/dx.common.css ./~/devextreme/dist/css/dx.light.compact.css ./~/ng2-dnd/style.css ./~/syncfusion-javascript/Content/ej/web/bootstrap-theme/ej.web.all.min.css

ERROR in ./~/syncfusion-javascript/Content/ej/web/bootstrap-theme/ej.web.all.min.css
Module build failed: ModuleBuildError: Module build failed: Missed semicolon (9:216745)

at runLoaders (node_modules\webpack\lib\NormalModule.js:192:19)
at node_modules\loader-runner\lib\LoaderRunner.js:364:11
at node_modules\loader-runner\lib\LoaderRunner.js:230:18
at context.callback (node_modules\loader-runner\lib\LoaderRunner.js:111:13)
at Object. (node_modules\css-loader\lib\loader.js:49:18)
at node_modules\css-loader\lib\processCss.js:228:4
at
at process._tickCallback (internal/process/next_tick.js:169:7)

This error is only shown when using ng build --aot --prod if I use only ng build, then this error doesn't show. I have tried this with version : 15.2.0.46 and version : 15.2.0.40.
Is there any solution for this?

I will begrateful foranyhelp you can provide.
Marko

Koushik Ramaswamy [Syncfusion]
Replied On July 19, 2017 12:02 PM UTC

Hi Marko,

Thanks for using Syncfusion products,

We could reproduce the reported issue “AOT build with bootstrap-theme” at our end. And we have logged a defect report regarding the same. A support incident to track the status of this defect has been created under your account. 

Please log on to our support website to check for further updates.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents 

Regards, 
Koushik R 


Robert Williamson
Replied On July 31, 2017 10:12 AM UTC

Hi Koushik R

Just wondering when this issue is resolved for us as we've come accross this similar issue with our project

Thanks

Robert


Marko
Replied On August 1, 2017 08:21 AM UTC

Hi Robert,

I recived the following answer:


We would like to let you know that the fix for the reported issue will be available in our Volume 3, 2017 which is estimated to be rolled out by first week of August. 



Robert Williamson
Replied On August 8, 2017 10:27 AM UTC

Hi Marko


Thanks, looks like it's available in the 15.3.26 version which got released yesterday.  just did a test on an AOT build and it looks like its worked 



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;