We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DatePicker value not being posted back on Safari (iPad)

Thread ID:

Created:

Updated:

Platform:

Replies:

131183 Jun 27,2017 11:28 AM UTC Jun 29,2017 05:15 AM UTC ASP.NET Core 3
loading
Tags: DatePicker
Mark Chidlow
Asked On June 27, 2017 11:28 AM UTC


The following code works on Chrome (PC) but NOT on Safari (iPad).

Other form control data IS posted back correctly e.g the Note control, BUT the MeetingDate is not.

<form asp-controller="Meetings" asp-action="New" asp-route-jobid="@Model.JobId" method="post">
    <ej-date-picker id="MeetingDate" ej-for="MeetingDate" date-format="dd/MM/yyyy" width="100%"></ej-date-picker>
     <textarea asp-for="Note" class="form-control" rows="5"></textarea>
    <input type="submit"value="Save">
</form>

Can you help?




Sasikala Nagarajan [Syncfusion]
Replied On June 28, 2017 04:58 PM UTC

Hi Mark, 
Thanks for contacting Syncfusion support, 

We are unable to get your query, can you please share the details about your issue that will help us to prompt solution. 

  1. Whether the controls even didn’t rendered properly in safari?
  2. Whether the controls renders fine in safari but not posting form values only?
 
Also, in your application we have noticed that you have set the difference date format to DatePicker. If you facing any this issue(formatting) in post back due to this DateFormat, then please use below code in your startup.cs file to resolve 

 
            var cultureInfo = new CultureInfo("en-US"); 
            CultureInfo.DefaultThreadCurrentCulture = cultureInfo; 
            CultureInfo.DefaultThreadCurrentCulture.DateTimeFormat.ShortDatePattern = "dd/MM/yyyy"; 


Regards, 
Sasikala Nagarajan  


Mark Chidlow
Replied On June 28, 2017 05:53 PM UTC

Thank you Sasikala. It appears that the date-format setting without the culture being set has caused the problem.

Again - great support from Syncfusion.



Sasikala Nagarajan [Syncfusion]
Replied On June 29, 2017 05:15 AM UTC

Hi Mark, 
We are glad to hear that the issue has been resolved in your end. Please get back to us if you need any further assistance, 
Regards, 
Sasikala Nagarajan  


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;