We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Problem with GridNumericColumn in touch-screen keyboard

I have the same issue as my incident on the WinRt version (Incident ID: 150917).

When I edit a GridNumeric cell in touch-screen mode, i can't type a value with the virtual keyboard. It seems that the keys are in the wrong place (ex: & types a 1). 
I have the framework version and my keyboard / local is FR-fr (french).


3 Replies

SV Srinivasan Vasu Syncfusion Team May 16, 2017 01:23 PM UTC

Hi Aurelien, 
Thanks for contacting Syncfusion support. 
We have analyzed your query and you can able resolve your reported problem by setting BlockCharactersOnTextInput property for GridNumericColumn as false. 
Please refer the below code example. 
                <Syncfusion:GridNumericColumn BlockCharactersOnTextInput="False" MappingName="OrderID" HeaderText="OrderID"/> 

AU Aurélien May 29, 2017 11:35 AM UTC

It works well !

SV Srinivasan Vasu Syncfusion Team May 30, 2017 04:53 AM UTC

Hi Aurelien, 
Thanks for your update. 
Please let us know if you need further assistance on this. 

Live Chat Icon For mobile
Up arrow icon