We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

RTE and unsorted list from word

Thread ID:

Created:

Updated:

Platform:

Replies:

129285 Mar 9,2017 09:20 AM Mar 15,2017 06:59 AM ASP.NET Web Forms 5
loading
Tags: RichTextEditor
Carsten Wuttke
Asked On March 9, 2017 09:20 AM

Hello,

i read a word-document  (docx) with the code in the samples into an rte-control. Then I have the possibility to download a word-file from the rte. Works good except:

Unsorted lists are obscured somehow. In the RTE the distances are to big(I have a case, where it even "gulps" the first letters of the text after the dot) between the lines.

When I then download the file either the UL is still obscured or the result misses the UL-Dots.

This even works with the samples provided. You can try it yourself with the doc in the zip.file. Perhabs someone has a solution?

Attachment: example_879d9a5f.zip

Gopi Govindasamy [Syncfusion]
Replied On March 10, 2017 04:44 AM

Hi Carsten,    
  
We have checked your reported scenario and imported your document and it was not obscured. By default, when you import a document into RTE, it will perform xhtml validation before inserting it. In xhtml validation, the elements without proper xhtml format will be removed and after validation the element will be imported in RTE.   
   
Please let us know if you need any other help.   
  
Regards,   
Gopi G.   


Carsten Wuttke
Replied On March 10, 2017 05:15 AM

Hello Gopi,

thats true. In this document it doesn't gulp the first letters. I have another one, where it does. Sadly I can't offer this for tests.

Where it gets obscured is the "download"-Part. Meaning: Out of the RTE I create with DOCIO a Word-Doc. There the UL misses its dots. If this is because of the XHTML-Validation then thats not good.

Regards,
Carsten

Gopi Govindasamy [Syncfusion]
Replied On March 13, 2017 07:37 AM

Hi Carsten,    
  
We were not able to reproduce the reported issue for RTE export document UL missing(dots). We have checked your scenario for RTE export word document ul not missing(dots) maintained in the document. We tried your attached document, and the issue was not reproduced. We have prepared a video and attached the link.    
  
      
Regards,   
Gopi G.   


Carsten Wuttke
Replied On March 14, 2017 11:54 AM

Hello,

thx for the vid. But I found the problem:
You are using Chrome aren't you? I am using Firefox as default browser. Well. Tried in in IE. There all goes well. I tried it with Firefox again. The error was there again. Sadly I couldn't open the localhost in Edge. So I tried your demos-Website. Wow. Looks different in Edge. (see screen) Also there is no Problem after Export. So seems that Firefox makes probs. Can you confirm?

Regards,
Carsten



Attachment: edge_c2594ac7.zip

Gopi Govindasamy [Syncfusion]
Replied On March 15, 2017 06:59 AM

Hi Carsten,  
 
We have checked RTE export document in firefox browser and we are unable reproduced the reported issue, and the shared details are not sufficient to understood your requirement, so could you please provide us more details to achieve your requirement? So, that we would be able to investigate further on your requirement and provide you a better solution. 
 
Regards, 
Gopi G. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;