We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Fresh Install - Error Message on Most Controls when building / designing

Thread ID:

Created:

Updated:

Platform:

Replies:

129000 Nov 26,2016 03:54 AM Feb 21,2017 04:34 AM Windows Forms 11
loading
Tags: Carousel
Danie van Eeden
Asked On November 26, 2016 03:54 AM

Hi,

I find the prospect of using SyncFusion control amazing and I'm very grateful for the community license.

However, finding it difficult to get started:

I have installed both Windows Forms and ASP Web Form controls. Everything is license according to the control panel.

When dropping a GridDataBoundGrid on the form (of a Ribbon menu component for that matter - I stopped testing other controls after that).
I get the error message below either when trying to Build the application or when assigning a Data Source to the grid control.

Googling I found a single thread that indicate the Assembly reference's SpecificVersion property should be set to false.
I tried this but it makes no difference. I tried switching frameworks for the project (forward and back) didnt make a difference.

Any thoughts on how to resolve this? Would be greatly appreciated - I am really stuck here.



---------------------------
Microsoft Visual Studio
---------------------------
Code generation for property 'RibbonHeaderImage' failed.  Error was: 'Type 'Syncfusion.Windows.Forms.Tools.RibbonHeaderImage' is not available in the target framework.'
---------------------------
OK   
---------------------------

Riubbon menu gives this on building:
---------------------------
Microsoft Visual Studio
---------------------------
Code generation for property 'RibbonHeaderImage' failed.  Error was: 'Type 'Syncfusion.Windows.Forms.Tools.RibbonHeaderImage' is not available in the target framework.'
---------------------------
OK   
---------------------------

Running the following version of  VS:
=================================
Microsoft Visual Studio Community 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01590


Kind Regards
Danie van Eeden



Danie van Eeden
Replied On November 26, 2016 04:07 AM

Additionally - I dropped a Navigation drawer and added a header and some items. Selecting the ellipses for the Header - Background image results in
---------------------------
Properties Window
---------------------------
Object reference not set to an instance of an object.
---------------------------
OK   
---------------------------

There is some incompatibility here. You help appreciated (once again)

Danie van Eeden
Replied On November 26, 2016 06:11 AM

Some feedback:
OK I seem to have found some sort of workaround, but I dont see how this could be a genuine fix.

Drop a new component - check which assemblies are added to the references.
Select them and Change CopyToLocal=False and SpecificVersion=False

Now the designer seems better - although the navigation drawer gives an "object not set to instance" error when adding a background image (still).

If this is the official fix how does this affect deployment? Should the assemblies be shipped with the application? And if so, would the same errors occur if (then) copied locally (with exe)?

Danie van Eeden
Replied On November 26, 2016 06:26 AM

OK some weird things going on - getting VS 2015 not responding errors during design mode as well.
This VS2015 is fairly a fairly new install and the issue only occur with SyncFusion components.

Amal Raj Umapathy Selvam [Syncfusion]
Replied On November 28, 2016 03:39 AM

Hi Danie, 

Thanks for using Syncfusion products. 

The reported exception while creating components as Code generation failed may occur when the referred assemblies and the target framework differences. The reported issue may occur when the target framework of the application is set as 4.5.2 and the referred assemblies of Syncfusion components are from 4.6, since Syncfusion components doesn’t support 4.5.1 framework. We need some more details about your scenario. Please update us the following details, 

·         If the target framework is 4.5.2, could you please change it to 4.5.1 or 4.6? and set Specific Version of assemblies to false for proper assembly references with target framework and assemblies. 
·         If the target framework is other than 4.5.2, could you please update us the target framework version and the assemblies of Syncfusion components version? 
·         Update us the product version of Syncfusion Essential Studio you are using. 
·         Update us the Controls you are using in your form. 

This will be very helpful for us to provide you a solution at the earliest. 

Regards, 
Amal Raj U. 


Danie van Eeden
Replied On November 29, 2016 04:08 PM

Hi,

thank you for the reply.

Details as requested below:

I will try changing to target framework 4.6 and respond with results as well.

See comments in bold
·         If the target framework is 4.5.2, could you please change it to 4.5.1 or 4.6? and set Specific Version of assemblies to false for proper assembly references with target framework and assemblies. My project target framework is 4.5.1 at the moment
·         If the target framework is other than 4.5.2, could you please update us the target framework version and the assemblies of Syncfusion components version? All assembly references show RuntimeVersion=4.0.30319 and Version=14.4451.0.15


·         Update us the product version of Syncfusion Essential Studio you are using.  Version of syncfusion is 14.4.0.15
·         Update us the Controls you are using in your form. Using RibbonControlAdv, GridDataBoundGrid (I only tried few, the problem may be with other controls as well)

Danie van Eeden
Replied On November 29, 2016 04:29 PM

Some feedback.

I spent set it to target framework 4.6 and set all the specificversion properties to false. 
I spent 30 minutes playing around with the controls and it seems much better.

The moment specific version is turned to TRUE, I start getting problems again.

Is their anyway to default the property to FALSE for all assemblies that are added automatically.?

When you drag a control, you don't always realize that an assembly was added (and as a result, you dont always set the property).

Amal Raj Umapathy Selvam [Syncfusion]
Replied On November 30, 2016 07:17 AM

Hi Danie, 

Thanks for the update. 

By default Specific version of the assemblies are set to true and it cannot be changed before adding assemblies to the project. 

In general, we will configure 4.6 framework for VS2015, if you set the target frame work of the project to any lower versions than 4.6 then the reported issues will occurs due to conflict between the target framework and the referred assemblies. This will be resolved when changing Specific Version to false. But this is not a standard way to resolve this issue. 

If you want to work with 4.5.1 framework Syncfusion assemblies in VS2015, you should integrate the toolbox with 4.5.1 assemblies. Please make use of the below KB link to configure the toolbox, 

KB Link 

Note 
For your case, configure 4.5.1 framework for VS2015. 

Regards, 
Amal Raj U. 


Danie van Eeden
Replied On November 30, 2016 01:21 PM

Thank you for the support.

I will try and work with 4.6 (and if needed will follow you link to the Toolbox integration for 4.5.1)

Should I experience more problems I will comment here.

Danie

Amal Raj Umapathy Selvam [Syncfusion]
Replied On December 1, 2016 12:11 AM

Hi Danie, 

Thanks for your update. 

We will wait until we hear from you. 

Regards, 
Amal Raj U. 


Danie van Eeden
Replied On February 20, 2017 01:05 PM

HI some feedback (if still relevant to this post) and a small issue during the testing.

I have installed .net 4.6 controls into the toolbox and I am targeting 4.6 with the project.

Most controls seem to work fine without issues. I have tried around 15 controls.

If I drop a carousel component and add a Picture box item - then select the initial image - i get:

Object reference not set to an instance of an object. 

I have tried turning off / on Specific Version - with the same result.

Any thoughts?

Kannan R [Syncfusion]
Replied On February 21, 2017 04:34 AM

Hi Danie,   
   
Thank you for your update.    
   
Please ensure if you have enabled “ImageSlides” property as True for using Image Slide items in Carousel. Please make use of below code example for your reference.    
   
Code Example: C#]   
   
   
//  To enable Image Slides   
this.carousel1.ImageSlides = true;   
//  To rotate always   
this.carousel1.RotateAlways = true;   
   
   
We have also prepared sample for your reference and it can be downloaded from below location.   
   
   
Kindly check with above solution and let us know if it is helpful.   
   
Regards   
Kannan  


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;