We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Color background in textnode??

Thread ID:

Created:

Updated:

Platform:

Replies:

128421 Jan 20,2017 05:14 AM Jan 24,2017 07:12 AM Windows Forms 5
loading
Tags: Diagram
Blanca Calderon
Asked On January 20, 2017 05:14 AM

Hi,

I have a big problem with text node. If I create a diagram with a textnode inside and transform .edd into .jpg the next node inside has background, has pixeles.

It is so important in my tool not having this.

Any help would be appreciated.



Attachment: pantalla1_3ffe73ba.zip

Blanca Calderon
Replied On January 20, 2017 07:21 AM

this.diagram1.ExportDiagramAsImage(true, ??);


I don't know if i have to modify this or it's when I create the textnode that I have to put color or similar.


Naganathan Ganesh Babu [Syncfusion]
Replied On January 23, 2017 02:22 AM

Hi Blanca, 
 
Thanks for contacting Syncfusion support. 
 
Please confirm us whether your requirement is to set the background color for TextNode and export it as Image? If yes, please refer to the below attached sample and let us know whether the reported issue is resolved or not at your end. 
 
Sample: 
 
 
If we misunderstood your requirement, please share us more details about your requirement probably a modified the attached sample to reproduce the reported issue at our end which will help us to analyze further and provide a better solution.  
 
Regards, 
 
Naganathan K G 
 


Blanca Calderon
Replied On January 23, 2017 03:27 AM

I've used your example to reproduce the problem. As you could see when the background color of the textnode is transparent pixels appear around the text.

Attachment: Desktop_83153332.zip

Blanca Calderon
Replied On January 23, 2017 04:07 AM

When I export my image as .bmp this doesn't happen but the text always have color. I need to export a jpg always in black & white, never with color or grey scale. This .jpg image is for a display in a PLC and never uses color.

If I try to convert my image .bmp into .jpg these pixeles appear again.

Naganathan Ganesh Babu [Syncfusion]
Replied On January 24, 2017 07:12 AM

Hi Blanca,
 
 
Please find the attached image and please confirm us whether you are mentioning the grey colored pixels highlighted inside the red box as an issue? If yes, this is not the diagram control issue. The jpeg format images are not rendered based on vector. So only the image is losing the quality while zooming. The Vector based images can be resized without to lose quality like Bmp/Png format images.  
 
Image: 
 
 
 
Please refer to the below online links for your references.  
 
 
 
Regards, 
Naganathan K G 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;