We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Unable to resolve Syncfusion.EJ.AspNet.Core

Thread ID:

Created:

Updated:

Platform:

Replies:

128017 Dec 27,2016 04:26 AM Jan 2,2017 08:45 AM ASP.NET Core 2
loading
Tags: Button
Anthony Irwin
Asked On December 27, 2016 04:26 AM

Hi,
I have tried downgrading my .net core to the version listed on your sitehttps://go.microsoft.com/fwlink/?LinkID=827517 and run sudo rm -Rf /usr/local/dotnet prior to installing it to make sure any newer versions was removed from my system but the problem still exists.
$ dotnet --info

.NET Command Line Tools (1.0.0-preview2-003156)


Product Information:

Version: 1.0.0-preview2-003156

Commit SHA-1 hash: 33dabee5d8


Runtime Environment:

OS Name: Mac OS X

OS Version: 10.11

OS Platform: Darwin

RID: osx.10.11-x64


$ nuget sources

Registered Sources:


1. SyncFusion ASP .NET Core [Enabled]

http://nuget.syncfusion.com/nuget_aspnetcore/nuget/getsyncfusionpackages/aspnetcore

2. SyncFusion Xamarin [Enabled]

http://nuget.syncfusion.com/nuget_xamarin/nuget/getsyncfusionpackages/xamarin

3. Nuget V2 [Enabled]

https://www.nuget.org/api/v2/


I created the project by doing the following:


$ mkdir ~/Projects/Syncfusion

$ cd ~/Projects/Syncfusion

$ dotnet new -t web


I then added:


"Syncfusion.EJ.AspNet.Core": "14.4600.0.15-preview2-final"


To the project.json file.


Then added:


"syncfusion-javascript": "14.4.15"


To the bower.json file.


when I run dotnet restore I get the following:


$ dotnet restore

log : Restoring packages for /Users/irwa82/Projects/Syncfusion/project.json...

error: Unable to resolve 'Syncfusion.EJ.AspNet.Core (>= 14.4600.0.15-preview2-final)' for '.NETCoreApp,Version=v1.0'.

log : Restoring packages for tool 'Microsoft.AspNetCore.Razor.Tools' in /Users/irwa82/Projects/Syncfusion/project.json...

log : Restoring packages for tool 'Microsoft.AspNetCore.Server.IISIntegration.Tools' in /Users/irwa82/Projects/Syncfusion/project.json...

log : Restoring packages for tool 'Microsoft.EntityFrameworkCore.Tools' in /Users/irwa82/Projects/Syncfusion/project.json...

log : Restoring packages for tool 'Microsoft.Extensions.SecretManager.Tools' in /Users/irwa82/Projects/Syncfusion/project.json...

log : Restoring packages for tool 'Microsoft.VisualStudio.Web.CodeGeneration.Tools' in /Users/irwa82/Projects/Syncfusion/project.json...

log : Lock file has not changed. Skipping lock file write. Path: /Users/irwa82/Projects/Syncfusion/project.lock.json

log : /Users/irwa82/Projects/Syncfusion/project.json

log : Restore failed in 10129ms.


Errors in /Users/irwa82/Projects/Syncfusion/project.json

Unable to resolve 'Syncfusion.EJ.AspNet.Core (>= 14.4600.0.15-preview2-final)' for '.NETCoreApp,Version=v1.0'.



I have tried everything I can think of but unable to get this to work.


It would be nice if you at least supported the current LTS version listed on Microsoftshttps://www.microsoft.com/net/download/core website as that is where you go to download the current dotnet core framework from. Microsoft has 1.0.3 as current stable LTS release, you seem to want 1.0.1 which I only found the link for as it was on your https://help.syncfusion.com/aspnet-core/getting-started-mac help page.


Also the yo aspnet tools for creating projects now uses dotnet core 1.1 so you can't use that tool to create projects as you are using outdated 1.0.1


I am a bit worried about investing time in learning your tools if it forces me to use older ancient releases of dotnet core. I would have thought that the latest stable LTS release would be supported.


https://www.microsoft.com/net/download/core is the current downloads for the technology from Microsoft. It would be nice if your tools worked with the default environment provided by Microsoft.


Any help getting your tools up and running would be nice. I have atached my project file.



Thanks,

Anthony



Attachment: Syncfusion_70533672.zip

Anthony Irwin
Replied On December 29, 2016 07:28 AM

Updated Info.

I have gotten Synfusion working. I removed the nuget v2 source from nuget and the packages are downloading now with dotnet restore.

I have also gotten it working with the current LTS release 1.0.3 from the microsoft website.

I think the main issue was that I had dotnet 1.1 installed and saw a screenshot of visual studio for windows showing the v2 nuget so I added the reference and then ended up down grading dotnet to the LTS version and it still wasn't working due the the v2 nuget reference.

It would be nice if it did work with 1.1 as it has major performance improvements over 1.0.x release according to Microsoft's blog posts about it. It would also allow the use of the yo aspnet command for creating new projects as it now has 1.1 references as default so for now the only way to create a project is dotnet new -t web.

Anyway apologies if I came across harshly in original post as it was very frustrating when I couldn't get it to load into a default project.

I will go through the documentation at https://help.syncfusion.com/aspnet-core/ and experiment with your product in a test project.

Thanks,
Anthony

Manikandan Mariappan [Syncfusion]
Replied On January 2, 2017 08:45 AM

Hi Anthony, 
  
Thanks for your update also happy to heard the issue gets resolved in your end. 
  
Please let us know, if you need any other further assistance on .NET Core implementation. 
  
Regards, 
Manikandan Mariappan 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;