We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

HighlightSearch working in JS example, but not Angular1 example

Thread ID:





127960 Dec 21,2016 06:08 PM UTC Dec 23,2016 11:47 AM UTC JavaScript 3
Tags: ejAutoCompleteTextBox
Thomas French
Asked On December 21, 2016 06:08 PM UTC

I was doing some testing on the JavaScript AutoCompleteTextBox and the Angular1 AutoCompleteTextBox and found that the 'highlightsearch' property does not work on the angular1 version of the control.

The JS example can be found here: http://js.syncfusion.com/demos/web/#!/bootstrap/autocomplete/multicolumn
The Angular1 example can be found here: http://ngjq.syncfusion.com/#/autocomplete/multicolumn

JavaScript autocomplete creation:
                dataSource: window.gridData,                fields: { key: "OrderID", text: "ShipCity" },
    highlightSearch: true,
    watermarkText: "Select a order",    width:"100%",    showPopupButton: true,    multiColumnSettings:{
    stringFormat: "{0}  ({3}) ({1})",    enable:true,    showHeader: true,
    columns: [
    {    field: "CustomerID",    headerText: "CustomerID",    },
    {    field: "OrderID",    headerText: "OrderID"    },
    {    field: "EmployeeID",    headerText: "EmployeeID"    },
    {    field: "ShipCity",    headerText: "ShipCity"    }

Angular1 autocomplete creation:
<input type="text" id="automulticolumn" ej-autocomplete e-datasource="multicolumndataList" e-fields-key="multicolumnkey" e-fields-text="multicolumntext" e-watermarktext="Select a Order" e-highlightserach="true" e-showpopupbutton="true" e-multicolumnsettings="multicolumncolset" e-width="100%" />

Is there a way to get the 'highlightsearch' property to work in Angular1, without switching completely over to the JavaScript version of the control?

Arun Palaniyandi [Syncfusion]
Replied On December 22, 2016 09:31 AM UTC

Hi Thomas, 
Thanks for contacting Syncfusion support. 
We have validated your shared code and found that the highlightsearch property is wrongly spelled. You have used e-highlightserach instead of e-highlightsearch in your code. So change the spell error with your application to enable highlight search for Autocomplete. 

Please let us know if you have any queries. 

Arun P 

Thomas French
Replied On December 22, 2016 01:47 PM UTC

Hey Arun,

Good catch on the spelling.
Just a heads up, the code sample that I pasted is from the Syncfusion Angular1 demo page for the AutoCompleteTextBox multicolumn.

Demo found here: http://ngjq.syncfusion.com/#/autocomplete/multicolumn
You may want to alert your team to the spelling error so that the demo page can be corrected and work correctly.

Thank you.

Ezhil S [Syncfusion]
Replied On December 23, 2016 11:47 AM UTC

Hi Thomas, 

We are glad the issue has been resolved in your end. 

Thanks for your feedback. We will update the demo page in our upcoming release. 
Please let us know if you need further assistance. 
Ezhil S 


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon