We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Vertical Scrollbar hides part of the diagram - how to avoid?

Thread ID:

Created:

Updated:

Platform:

Replies:

127598 Nov 26,2016 07:38 PM UTC Dec 8,2016 10:48 AM UTC JavaScript 4
loading
Tags: ejDiagram
Jim Jacobs
Asked On November 26, 2016 07:38 PM UTC

Hi,

Watch the attached video.
As you can see the vertical scrollbar hides a small portion of the right side of the diagram.
This is somewhat annoying.
Is there some way to avoid this?

Thanks for any advice.

Jim

Attachment: Syncfusion__Vertical_Scrollbar_covers_part_of_the_diagram__how_to_avoid__26nov2016_dc8d4e2d.zip

Shyam G [Syncfusion]
Replied On November 28, 2016 12:46 PM UTC

Hi Jim, 

If we set a scrollLimit as diagram, the diagram can be moved within the diagram view(based on diagram width). To resolve your reported issue, please set a diagram’s scrollLimit as Infinity or multiplePage as true. Please refer to the code example below. 

Code example: 

jsonData.pageSettings.multiplePage=true 
diagram.load(jsonData) 

Regards, 
Shyam G 


Jim Jacobs
Replied On November 28, 2016 01:48 PM UTC

Hi Shyam,

I've tried the following 3 things, all without success (i.e., the vertical scrollbar continues to cover up the right side of the diagram):

//$("#DiagramContent").ejDiagram({
//    pageSettings: { scrollLimit: ej.datavisualization.Diagram.ScrollLimit.Infinity }
//});
 
//$("#DiagramContent").ejDiagram({
//    pageSettings: { multiplePage: true }
//});
 
$("#DiagramContent").ejDiagram({ enableAutoScroll: false });
Is there any way to turn off the scrollbar altogether?
I can enable scrolling on the containing control.
That would actually be preferable, so I'm hoping you can show me how to turn the scrollbars off.

Thanks

Jim

Jim Jacobs
Replied On December 6, 2016 03:55 PM UTC

Hi,

Any further suggestions?
I realize I've been keeping you busy with incidents, but I'd still like to be able to get rid of the scrollbars.

Thanks for any ideas.

Jim

Kameshwaran R [Syncfusion]
Replied On December 8, 2016 10:48 AM UTC

Hi Jim, 
 
We have rendered the scroll bar inside the diagram area. So only the scroll bar hides the node. Please add padding to scroll settings to resolve your reported issue. 
 
Code snippet: 
 
            $("#diagram").ejDiagram({ 
                scrollSettings: { 
                    padding: { 
                        left: 0, right: 18, // 18 is the width of the horizontal scroll bar  
                        top: 10, bottom: 10 
                    } 
                } 
            }); 
 
Regards, 
Kameshwaran R. 
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;