We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

How to remove the scroll bar in gridcontrol?

Thread ID:

Created:

Updated:

Platform:

Replies:

12684 Apr 7,2004 01:22 PM Apr 8,2004 08:41 AM Windows Forms 2
loading
Tags: GridControl
chris
Asked On April 7, 2004 01:22 PM

Hi I have a gridcontrol whihc will always hold 4 row (9 column) data. I put it in a panel (dock as fill) and its size is fixed. If I load the data, no scrollbar will show up. However, if I do not load the data, the grid will always show scrollbar though the grid is empty. How can I disable the scrollbar and never let it show up? Thanks a lot Chris

Administrator [Syncfusion]
Replied On April 7, 2004 07:17 PM

Hi Chris, Have you tried setting the HScrollBehavior and/or VScrollBehavior properties on the grid? //C# this.gridControl1.HScrollBehavior = GridScrollbarMode.Disabled; this.gridControl1.VScrollBehavior = GridScrollbarMode.Disabled; ’VB.NET Me.GridControl1.HScrollBehavior = GridScrollbarMode.Disabled Me.GridControl1.HScrollBehavior = GridScrollbarMode.Disabled Regards, Jay N

chris
Replied On April 8, 2004 08:41 AM

Thanks. It works. Actually, I tried to disable scrollbar from the Property Window in VS Studio. SOmehow, I can not find VScrollBehavior propery. After disabling it by typing in the codes, it works. >Hi Chris, >Have you tried setting the HScrollBehavior and/or VScrollBehavior properties on the grid? > > >//C# >this.gridControl1.HScrollBehavior = GridScrollbarMode.Disabled; > >this.gridControl1.VScrollBehavior = GridScrollbarMode.Disabled; > >’VB.NET >Me.GridControl1.HScrollBehavior = GridScrollbarMode.Disabled > >Me.GridControl1.HScrollBehavior = GridScrollbarMode.Disabled > > >Regards, >Jay N

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;