We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

DataboundGrid with and without checkbox

Thread ID:

Created:

Updated:

Platform:

Replies:

12649 Apr 6,2004 12:41 PM Apr 6,2004 05:24 PM Windows Forms 1
loading
Tags: GridControl
Jose Luis Melo
Asked On April 6, 2004 12:41 PM

Hi, I have two forms and one DataboundGrid in each one. Each grid is inside their group box. The grid''s properties are axactly the same. I copy and paste the code from one to another. Selecting the same DataTable to the DataSource of each grid, there is one difference. This table has boolean fields, and in the first DataBoundGrid the boolean field appears with the "False" ou "True" word, and in the second DataBoundGrid the boolean field appears with a check box !!! I would like to put them with the same values. Do you have any idea why this happens ? How can I put the table with the same apearance (with the checkbox is better) Thanks for your time, Jose Melo

Administrator [Syncfusion]
Replied On April 6, 2004 05:24 PM

Normally, the grid auto-senses a boolean datacolumn datatype, and sets the CellType = "CheckBox". I am not sure why it is not doing this in this case? Are you explicitly adding GridBoundColumns for the grid that does not show the checkbox? If so, you should set the grid.GridBoundColumns["myColumn"].StyleInfo.CellType = "CheckBox"; for that column (and also set GridBoundColumn.StyleInfo.CellValueType = typeof(bool); If you are not adding GridBoundColumns, then set these properties on the grid.Binder.InternalColumns instead of grid.GridBoundColumns.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;