We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Performance with relationships between tasks (Predecessors)

Thread ID:

Created:

Updated:

Platform:

Replies:

123539 Mar 28,2016 07:47 AM May 22,2018 08:23 AM JavaScript 5
loading
Tags: ejGantt
yaaami
Asked On March 28, 2016 07:47 AM

In referenced link, that concentrates on performance:

http://jsplayground.syncfusion.com/bnpejqib

the execution time is: 13,245 s.

when I added a lag value to predecessors of each child task (like in commented line); the execution time may take up to: 45,404 s.

when I put more complicated relationships (real projects); the Gantt hang and may respond after long time (more than minute) !

I need a solution to render large number of task with complicated relationships. 

Mahalakshmi Karthikeyan [Syncfusion]
Replied On March 29, 2016 08:25 AM

Hi Yaami,

Sorry for the inconvenience caused.

We can able to reproduce the time delay while rendering large data with predecessors enabled. So we have logged a feature report regarding this to optimize the time to render Gantt. We have already updated response in the incident that has been created under your account to track the status of this requirement. Please log on to our support website to check for further updates.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents

Please let us know if you require further assistance on this.

Regards,

Mahalakshmi K.


yaaami
Replied On April 3, 2016 05:17 AM

I found a solution to decrease start-up time to be very very short, by disabling this function: _validatePredecessorDates.

Mahalakshmi Karthikeyan [Syncfusion]
Replied On April 4, 2016 09:01 AM

Hi Yaami,

We couldn’t remove this method call apparently, as it will not work in all the scenarios, also please follow up with the incident already created under your account regarding this feature for further details.

Regards,

Mahalakshmi K.


Ruchik Vora
Replied On May 21, 2018 07:36 AM

I found a solution to decrease start-up time to be very very short, by disabling this function: _validatePredecessorDates.

I would like to know how to disable the function you've mentioned as I am also facing a performance issue. There are around 40k activities and 70k links between activities.

Punniyamoorthi Elangovan [Syncfusion]
Replied On May 22, 2018 08:23 AM

Hi Ruchik, 
Thank you for contacting Syncfusion support. 
We have already improved the performance in Gantt while rendering large data with predecessors enabled, from the release version 14.1.0.46. And it is not possible to disable the method _validatePredecessorDates, as this is an internal method, instead you can disable the predecessor validation at initial load by disabling the enablePredecessorValidation property in Gantt. 
We have prepared the sample with 1500 records for your reference. Please find the sample link from the following link. 
Please let us know if you require further assistance on this. 
Regards, 
Punniyamoorthi 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;