We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to disable editing of RichText CellType in EssentialGrid

Thread ID:

Created:

Updated:

Platform:

Replies:

123528 Mar 26,2016 06:27 PM UTC Mar 30,2016 06:47 AM UTC WPF 3
loading
Tags: GridControl
yalcin oksuz
Asked On March 26, 2016 06:27 PM UTC

Hello

if I didn't miss any point in documentation, only way to disable editing is done by setting CellType to "Static" in GridControl

I want to disable editing of cell. One thing I tried is to set IsEditable property to false but it does not work.

_grid.Model[0,0].IsEditable = false;

For a code snipped like below, how can I disable editing? Thanks in advance

_grid.Model[0,0].CellType = "RichText";
          
 
FlowDocument flowDocument = new FlowDocument();
 
Paragraph paragraph = new Paragraph()
Run run1 = new Run(); run1.Text = deger; run1.Foreground = Brushes.Black; run1.FontSize = 14;
paragraph.Inlines.Add(run1);
flowDocument.Blocks.Add(paragraph);
_grid.Model[0,0].CellValue = flowDocument  
 









Kanimozhi Bharathi [Syncfusion]
Replied On March 28, 2016 12:47 PM UTC

Hi Yalcin Oksuz,

Thank you for contacting Syncfusion support.

You can disable the edit operation in the cell by using  “ReadOnly” property of GridStyleInfo in QueryCellInfo Event of GridControl like below code example,

grid.QueryCellInfo += grid_QueryCellInfo;


void grid_QueryCellInfo(object sender, GridQueryCellInfoEventArgs e)

{

      e.Style.ReadOnly = true;
}


Regards
Kanimozhi B

yalcin oksuz
Replied On March 29, 2016 11:08 AM UTC

I solved my problem using QueryCellinfo based on the example code, thank you.

Note: I checked documentation, setting readonly mode using QueryCellInfo was mention in gridTreeControl, I missed that part may be applied to gridControl too.

Kindest regards
Yalçın

Kanimozhi Bharathi [Syncfusion]
Replied On March 30, 2016 06:47 AM UTC

Hi Yalcin Oksuz,
Thank you for your update.
Regards
Kanimozhi B

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;