We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Authentication Required prompt when using Host Name instead of Port Number

Thread ID:

Created:

Updated:

Platform:

Replies:

123515 Mar 23,2016 06:57 PM Oct 18,2017 08:07 AM Report Platform 5
loading
Tags: Report Server
Louis Lavin
Asked On March 23, 2016 06:57 PM

When installing the Report Server on IIS, a port number is selected.  Once the IIS setup completes, we added bindings for our external domain.  As part of this test we added binding for the external domain on both port 80 and the port used in the ReportServerIIS.exe setup.  For example:

Site Bindings
Type    Host Name    Port    IP Address
http                           59958 *
http    syncfusion.test.com  80  *
http    syncfusion.test.com  59958  *

When accessing the report server over syncfusion.test.com:59958, everything is working fine.  When accessing the report server over syncfusion.test.com:80, we get a second authentication required prompt looking for a login.  No matter what you enter into that prompt you will not be authorized to access the Reports tab on the site.

Do you know what is causing the authentication prompt, and how to avoid this problem?

Thank you,
Louis



Venkatesan Rethinam [Syncfusion]
Replied On March 24, 2016 07:50 AM

Hi Louis,

Sorry for the inconvenience.

A support incident has been created under your account for the reported query. Please log on to our support website to check for further updates

http://www.syncfusion.com/support/directtrac/incidents 

Thanks,
R. Venkatesan

Ben Murphy
Replied On October 12, 2017 01:37 PM

Is there an answer for this? I have the same issue. I created a subdomain (reports.mydomain.com) and created a binding in iis. I can hit that website and it opens the login page for the report server.


When I go to my website (reports.myWebsite.com) Here is the login screen I can see: 


Here is the prompt for server login credentials I see after logging in above: 


Here are my bindings in iis:


If I choose to enter my server login credentials, it will log me into the report server and I am able to use the report server. Any ideas to prevent the server login.

My windows firewall is currently turned off in order to help troubleshoot this issue.


Subha Sukumaran [Syncfusion]
Replied On October 13, 2017 08:04 AM

Hi Louis,  

Sorry for the inconvenience. We are unable to reproduce the issue in our side. Could you please let us know whether you installed the Syncfusion Report Server automatically to IIS or else hosted the application in IIS manually ? 

Although, we have analyzed in our side and the possible scenarios are listed below,  

  1. Could you please check whether the Authentication of your application is set by this way ?
(Open IIS -> Select your Web Application -> Double click on the “Authentication” listed in the main panel)  

 
  1. Windows Authentication and ASP.NET Impersonation should be Disabled
  2. Forms Authentication and Anonymous Authentication should be Enabled

Regards, 
Subha 


Ben Murphy
Replied On October 17, 2017 07:25 AM

I just got off the phone with Syncfusion and here was the answer for me:

SSRS by default registers the URL “/reports” for it to display the SSRS web manager. 
We changed this to some other URL and the Syncfusion report server now works without any issues. 

Hope this helps someone else someday.


Arasuraja Balakrishnan [Syncfusion]
Replied On October 18, 2017 08:07 AM

Hi Carlos, 
 
Thanks for the response. 
 
It is the general conflicts occurred between the Syncfusion Report Server and SSRS. 
 
If you have installed SSRS in your machine, it has reserved the virtual directory as ‘/reports’. 
 
Hence after logged into the Syncfusion Report server, it will be redirected into http://localhost:80/reports, at this time the window authentication popup will be appears in Syncfusion Report Server. 
 
The solution for this issue is to update the virtual directory of the SSRS configuration, Please follow the steps in the below article to update the virtual directory. 
 
 
Now you can able to login into the Syncfusion Report Server without any issues. 
 
Please let us know if you need further assistance on this. 
 
Thanks, 
Arasuraja B. 
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;