We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

404 error on production server! Frustrating!

Thread ID:

Created:

Updated:

Platform:

Replies:

123467 Mar 20,2016 05:27 PM Mar 22,2016 11:46 AM ASP.NET MVC 5
loading
Tags: Grid
nid15
Asked On March 20, 2016 05:27 PM

Hello,

We have spent days trying to figure this out and we still cannot get it to work. It works fine on the development machine but once we publish and copy the folder over to the production IIS, it does not work. It has been very frustrating.
- Both devel and prod machines are WS2008R2 with IIS 7.5 The devel machine has VS2015 installed on it. We have built an ASP.NET MVC application starting with syncfusion project and using grid control. Works fine. When we publish from VS with filesystem and upload via ftp to prod IIS, we keep getting 404 error. We have tried referencing the web.config assembly with and without the "version etc" attributes to force it to pick from bin or from GAC. We have tried to install the DLL's in prod using the gacutil exe copied over from devel. It provides confirmation when the exe is run. Nothing seems to work. The only thing we have not tried is to install the full syncfusion essentials studios on the prod server.  Please note that if we create a regular asp.net mvc project without syncfusion then it works fine on production server.

Thanks

Jayaprakash Kamaraj [Syncfusion]
Replied On March 21, 2016 08:17 AM

Hi Nihar,

Thanks for contacting Syncfusion support.

Query1 : We have tried to install the DLL's in prod using the gacutil exe copied over from devel.

No Need to register each dll file using powershell or GACutil, we are directly include required dll’s in bin folder and refer form it.
 
Query 2: we keep getting 404 error

We were unable to reproduce the issue. please share the following information to find the cause of the issue.

1.       Attach screenshot of the issue.
2.       Issue occurs while initial rendering of Grid or any operations performed in Grid ?
   
Regards,

Jayaprakash K.

nid15
Replied On March 21, 2016 08:23 AM

Thanks for the quick reply. The site does not load at all. Gives the "folder browsing not enabled error" and none of the views open if we try to manually gI've the address. Do you have a sample vs2015 .net mvc project with syncfusion dll's present which we can build and publish or do you have a video of the same?

Mikhail Krasnobaev
Replied On March 21, 2016 10:10 AM

Thanks for the quick reply. The site does not load at all. Gives the "folder browsing not enabled error" and none of the views open if we try to manually gI've the address. Do you have a sample vs2015 .net mvc project with syncfusion dll's present which we can build and publish or do you have a video of the same?

It is probably an IIS error. Check here http://stackoverflow.com/questions/2374957/asp-net-mvc-on-iis-7-5

nid15
Replied On March 21, 2016 10:17 AM

Thanks for the quick reply. The site does not load at all. Gives the "folder browsing not enabled error" and none of the views open if we try to manually gI've the address. Do you have a sample vs2015 .net mvc project with syncfusion dll's present which we can build and publish or do you have a video of the same?

It is probably an IIS error. Check here http://stackoverflow.com/questions/2374957/asp-net-mvc-on-iis-7-5

It works perfectly fine if we have a normal non-syncfusion asp.net mvc application. It is a live server in production

Jayaprakash Kamaraj [Syncfusion]
Replied On March 22, 2016 11:46 AM

Hi Nihar,

Thanks for the update.

We have created sample in Asp.net MVC5  vs2015 and hosted the sample in server. Please  refer to the following instructions while hosting vs2015 Asp.net mvc5 sample in server.

1.       Need to set runAllManagedModulesForAllRequests as true in module for webconfig file.

Web.Config

<system.webServer>

    <validation validateIntegratedModeConfiguration="false" />

    <modules runAllManagedModulesForAllRequests="true" >

      <remove name="FormsAuthenticationModule" />
    </modules>


2.       Add required dlls in bin folder.

Please refer to the following hosting link and sample.

Link: http://staging.syncfusion.com:800/mvc5/Grid/GridFeatures

Sample: http://www.syncfusion.com/downloads/support/forum/123467/ze/SyncfusionMvcApplication611183860536


If you still facing the issue, Please share us the Asp.Net MVC version it will helpful to give prompt solution to you.

Regards,

Jayaprakash K.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;