We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

memory leaks in syncfusion UWP controls

Thread ID:

Created:

Updated:

Platform:

Replies:

122142 Feb 19,2016 04:08 PM UTC May 29,2017 03:46 AM UTC UWP 9
loading
Tags: SfDataGrid
Thibault
Asked On February 19, 2016 04:08 PM UTC

Hello,

I have some troubles with your  Essential Studio for UWP demo application as well as pages in my own application embedding Syncfusion controls (in my case Sfdatagrid and accordion).
It seems to have some kind of memory leaks. could you confirm this?
 this behavior appear for all your samples in Essential Studio for UWP demo application. Memory doesn't stop to increase when navigatng between  the pages. 
In the app i developp, where i use SF controls, the memory used in pages with SF controls is not released.
best regards,
Thibault

Leigh
Replied On February 22, 2016 12:42 AM UTC

I see the same issues with my applications.

Controls I'm using are the latest chart and Gauge for UWP.

If anyone could help that would be great.

Sowndaiyan Paulpandi [Syncfusion]
Replied On February 24, 2016 11:16 AM UTC

Hi Thibault,

Thanks for contacting Syncfusion Support.


We have created the support incidents under your account to track the status of this requirement. Please log on to our support website to check for further updates.


https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents



Regards,

Sowndaiyan


Sowndaiyan Paulpandi [Syncfusion]
Replied On February 24, 2016 11:18 AM UTC

Hi Leigh,

Thanks for contacting Syncfusion Support.

Could you please provide more information regarding the usage of chart in your application and please provide a simple sample to reproduce the problem. It would be helpful to provide a proper solution.


Regards,

Sowndaiyan


Danil
Replied On March 4, 2016 11:31 AM UTC

Hello,

I have same issue with my application.
Explanation:

1.I have 1 datagrid binded to ObservableCollection<customDto> (that contains +- 3500 objects)
2.One button to reload data.

Each time I click on button I create new ObservableCollection<customDto> and rebind to DataGrid
And each time I see memory consumption increase in Diagnostic Tool in Visual Studio ( with same number ex: 20Mb for each rebinding)

Thanks

Sowndaiyan Paulpandi [Syncfusion]
Replied On March 9, 2016 03:24 PM UTC

Hi Danil,

Thanks for contacting Syncfusion Support.


We have created the support incidents under your account to track the status of this requirement. Please log on to our support website to check for further updates.


https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents



Regards,

Sowndaiyan


TONY HENRIQUE
Replied On December 17, 2016 03:28 PM UTC

I also think there is some Memory Leak, 
I downloaded, added the reference, then the ToolBox is showing strange border lines,

The IDE becomes slow, the Build is extremally slow.

Now I drop on a simple screen a sfDigitalGauge. THe IDE freezes for 30 seconds
I edited the Value property . Now the IDE crashed, and restarted.

Now I added the sfDigitalGauge again. then hit PLAY
on Local Machine it takes almost 1 minute to run this simple screen with Syncfusion controls assembly DLL 
The Deply to device takes 5 minutes, 
>Copying files: Total 346 mb to layout...

If I remove the reference to SyncFusion controls for UWP, then everything becomes normal.
and 1>Copying files: Total 6 mb to layout...


Attachment: crazytoolbox_1b0d7a9e.zip

Nijamudeen Mohamed Sulaiman [Syncfusion]
Replied On December 19, 2016 06:49 AM UTC

Hi Tony,

Thanks for contacting Syncfusion Support.

We have found similar support incident under your account to track the status of the requirement of memory leak in SfDigital. Please log on to our support website to check for further updates.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents

Regards,
Nijamudeen M. 


Chris Wells
Replied On May 24, 2017 07:05 PM UTC

I am having the same issue.  The IDE is very slow.  the XAML designer takes forever whenever I reference the SfDataGrid.  When I remove the reference to sf everything is normal.  I am using VS 2017.  Is there a fix for this because I cannot use these controls if the environment is going to respond like this.  Thank you.

Srinivasan Vasu [Syncfusion]
Replied On May 29, 2017 03:46 AM UTC

Hi Chris,

Thanks for contacting Syncfusion Support.

We have created the support incidents under your account to track the status of this requirement. Please log on to our support website to check for further updates. 
 


Regards,
Srinivasan 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;