We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

FirstDayOfWeek attribute

Thread ID:

Created:

Updated:

Platform:

Replies:

122074 Feb 14,2016 01:13 PM UTC Feb 17,2016 03:52 AM UTC WinRT 5
loading
Tags: SfSchedule
Lee Khen
Asked On February 14, 2016 01:13 PM UTC

I'm using FirstDayOfWeek="Monday", and my application localize is "fr-FR"
When I'm running my application on windows 10, I have a gap on the calendar.

For Example - 1.2.2016 shows as Sunday, Instead of 31.1.2016 , but when I remove this attribute, every thing works fine.



Venkateshwaran Ramdoss [Syncfusion]
Replied On February 15, 2016 09:35 AM UTC

Hi Lee,

We have checked your reported issue by creating a simple sample. In this sample we have used 'FirstDayofWeek' as 'Monday' and 'Culture' as 'fr-FR'. We were not able to reproduce the reported issue at our end. Please download the sample from the below link. Can you please give some more information about your reported issue like modifying sample and providing replication steps? It will help us to proceed further.

Sample: SfCalendarSample

Regards,
Venkateshwaran V.R.


Lee Khen
Replied On February 15, 2016 09:56 AM UTC

Thank you for the quick reply.

I'm using "SfSchedule" component and not "SfCalendar".

Code sample:

 xmlns:syncfusion="using:Syncfusion.UI.Xaml.Schedule"  

 <syncfusion:SfSchedule x:Name="Schedule1" FirstDayofWeek="Monday"</syncfusion:SfSchedule>

Thanks.


Vigneshkumar Ramasamy [Syncfusion]
Replied On February 16, 2016 04:56 AM UTC

Hi Lee,

Thanks for your update.

We are unable to reproduce the mentioned issue of “1.2.2016 shows as Sunday, Instead of 31.1.2016” when setting FirstDayOfWeek in schedule control. We have created simple sample in schedule using FirstDayOfWeek as Monday and Culture as “fr-FR”. Please find the sample in the below link.

Sample Link: SfSchedule_Sample

Could you please modify the above sample or else provide the replication procedure to reproduce the issue and revert us back? So that we can analyze on the issue further and provide you a possible solution.

Please let us know if you have any concerns

Regards

Vigneshkumar R


Lee Khen
Replied On February 16, 2016 07:31 AM UTC

Thanks you for your reply.

When I set the primary language in the constructor of controller page, every thing is Ok.

Thanks you for your support.



Vigneshkumar Ramasamy [Syncfusion]
Replied On February 17, 2016 03:52 AM UTC

Hi Lee,

We are glad to hear that your issue has been resolved. Please let us know if you need further assistance on this.

Regards

Vigneshkumar R


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;