We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Issue with PdfViewerControl

Thread ID:

Created:

Updated:

Platform:

Replies:

121601 Jan 6,2016 09:42 AM UTC Jan 18,2016 11:45 AM UTC WPF 7
loading
Tags: PdfViewer
atul
Asked On January 6, 2016 09:42 AM UTC

Hi All,

I am using Syncfusion.PdfViewer.WPF.dll of version 13.1450.0.21 and i am facing one issue while loading the pdf from PdfViewerControl.
Issue details:
I am using PdfViewerControl to display the report of my application, if my report contains the text \456 the report gets distorted and the data after the \456 is not displayed in viewer control.
I have attached the image of distorted report.
Can anyone help me out here please.

Thanks And Regards
Atul,

Attachment: SyncFusionDistortedReport_b28ae9a9.7z

Parthipan R [Syncfusion]
Replied On January 7, 2016 09:11 AM UTC

Hi Atul,

Thank you for using Syncfusion Products.

We regret to let you know that we could not reproduce the reported issue at our end with the provided details. We tried to reproduce the issue with the sample available in the following link. Please try with this sample at your end and revert with the modified sample to reproduce the issue. Also please provide the reproducing steps or document(if any) having  this issue, it would be helpful for us to investigate more on this and to provide you appropriate solution.
http://www.syncfusion.com/downloads/support/directtrac/general/ze/PdfViewer_WPF1488913371
Regards,
Parthipan


atul
Replied On January 8, 2016 05:00 AM UTC

Hi Parthipan,
I have gone through you sample code. I have tried by opening my sample PDF  with application and its giving same issue.
I have attached the sample PDF can you pleas try at your side and do the needful. 


Attachment: PlateInformation_ad439a55.zip

Parthipan R [Syncfusion]
Replied On January 11, 2016 08:33 AM UTC

Hi Atul,

Thank you for your update.

We have analyzed the provided PDF document. We are able to reproduce the issue “Document content does not render properly” using PdfViewer WPF control in Essential Studio version 13.3.0.7. We are glad to let you know that the issue “Document content does not render properly” has been resolved internally. The fix for this issue will be included in our Essential studio Volume 4 release which is estimated to roll out in the mid of January, 2016. 

We will update you once the Essential Studio volume 4 release is available for download. Please upgrade to the same to get this issue resolved.

Regards,

Parthipan


Parthipan R [Syncfusion]
Replied On January 14, 2016 06:43 AM UTC

Hi Atul,

We are glad to announce that our Essential Studio Volume 4, 2015 is rolled out and is available for download under the following link.

http://www.syncfusion.com/forums/121657/essential-studio-2015-volume-4-final-release-v13-4-0-53-is-available-for-download                                              

We thank you for your support and appreciate your patience in waiting for this release. Please get in touch with us if you would require any further assistance.

Regards,

Parthipan


atul
Replied On January 15, 2016 11:35 AM UTC

Hi Parthipan,
Thanks for you updates!!!!
I have downloaded the latest version dll's and used in my project, the original issue  is get resolved on latest version but i found one issue with latest version if i closed the PDF viewer my application also gets closed.
Steps In details:-
1) Print the document --> PDF viewer will get open will get open in new window.
2) Close the PDF viewer, Observe the application will get closed.

Regards,

Atul


atul
Replied On January 15, 2016 11:53 AM UTC

Hi Parthipan,
I have modified you solution according to my requirement kindly go through it, It will be easy to reproduce the issue.

Regards,
Atul

Attachment: PdfViewer_WPF_8650fc0a.7z

Balasubramanian Sundararajan [Syncfusion]
Replied On January 18, 2016 11:45 AM UTC

Hi Atul,

Thank you for your update.

We are able to reproduce the issue with the sample provided by you in your last update. We have create a separate incident under your account. Kindly log on to the below link to follow up on the incident created,

https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents

Thanks,
Balasubramanian S

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;