We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

StackingColumnSeries labels getting cut off

Thread ID:

Created:

Updated:

Platform:

Replies:

121188 Nov 17,2015 10:04 PM UTC Nov 19,2015 12:42 PM UTC WinRT 3
loading
Tags: SfChart
Cameron Flores
Asked On November 17, 2015 10:04 PM UTC

I have an sfChart which uses several StackingColumnSeries to create a display like what is seen below:


In order to get the label on top of the chart, I had to use a labeltemplate for the chart adornment.  Is this the correct approach?  I ask because I'm running into an issue which can be seen below, where the label is occasionally cut off (this only seems to happen for the chart on the left side by the way):



I'm not sure how to get the column to adjust so it's not up against the edge (and therefore not displaying the label).  Thanks.

Santhiya Arulsamy [Syncfusion]
Replied On November 18, 2015 02:48 PM UTC

Hi Cameron,

Thanks for contacting Syncfusion support.

We have analyzed your requirement. Could you please confirm the following image as your requirement?

Please let us know, if this is your requirement.

Screenshot: Column_Series_Auto_2

Thanks,

Santhiya A.

Cameron Flores
Replied On November 18, 2015 03:48 PM UTC

Hi,

Thanks for the reply.  I looked at your screenshot and that's close to what I'm trying to accomplish, but not quite.  The difference is, for the far left column where you're showing the adornment position as below, I still want it to be above - just not cut off.  Currently it gets cut off sometimes.  So I guess I want, in your example, for the maximum Y-Value to be 32, so that the adornment is able to still be on top of the bar and not get cut off.  Does that make sense?  Thanks again.

Santhiya Arulsamy [Syncfusion]
Replied On November 19, 2015 12:42 PM UTC

Hi Cameron,

Thanks for your update.

You can achieve your requirement by setting the RangePadding property value as “Normal” in NumericalAxis. Please refer the following code sample.
 

[XAML]

<chart:SfChart.SecondaryAxis>


<chart:NumericalAxis RangePadding="Normal"/>


</chart:SfChart.SecondaryAxis>



Please refer to the following UG link for further information.

http://help.syncfusion.com/winrt/sfchart/axis

Thanks,
Santhiya A

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;