We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Subreports

Thread ID:

Created:

Updated:

Platform:

Replies:

119770 Jul 29,2015 03:09 PM UTC Aug 3,2015 09:20 AM UTC ASP.NET MVC 3
loading
Tags: ReportViewer
Andrea Perazzolo
Asked On July 29, 2015 03:09 PM UTC

Hi,
I am trying to render a report that contains a subreport (Uploaded in the Attachment.
These reports have both an embedded Datasource (the same one), but in the best scenario, I'll need to use the trick you provided me for using the Shared Datasource and embed the connection data at Runtime.
The Problem is that there is an error when I render the main one, it says that the Subreport cannot be null.
I haven't found any sample that shows if there are additional steps when Rendering a subreport.
Could you help me in this scenario?
I put the reports in the App_Data directory and loaded locally, not publishing to a SSRS Server

    Thanks in advance

     Andrea Perazzolo

Attachment: App_Data_638c3f31.zip

Nithya B [Syncfusion]
Replied On July 30, 2015 03:35 PM UTC

Hi Andrea,
 

Sorry about the inconvenience caused.

As now, we doesn’t have support for “Stream property of SubReportModel ”. However we have consider this as defect and we have logged defect report regarding this. A support incident to track the status of this defect has been created under your account. Please log on to our support website to check for further updates
https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents 

 
Please let us know if you have any questions on this.
 
Regards,
Nithya B

Andrea Perazzolo
Replied On July 31, 2015 07:27 AM UTC

Hi,
I am not able to use the Subreports even when there is the DataSource embedded in the report and not using the Stream Property.
If I debug the WebAPI Controller of the Report, in the ReportOption parameter, the SubReportModel is Always null.
The SubReport file is in the same directory of the main Report.
I have not seen any example regarding SubReports in RDL Format.

    Thanks in advance

Soundara Rajan S [Syncfusion]
Replied On August 3, 2015 09:20 AM UTC

Hi Andrea,

Sorry about the inconvenience caused.

I am not able to use the Subreports even when there is the DataSource embedded in the report and not using the Stream Property.
If I debug the WebAPI Controller of the Report, in the ReportOption parameter, the SubReportModel is Always null.
We are able to reproduce the problem and have logged defect report regarding this. A support incident to track the status of this defect has been created under your account. Please log on to our support website to check for further updates
https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents
The SubReport file is in the same directory of the main Report.
I have not seen any example regarding SubReports in RDL Format.
We have prepared sample based on your requirement and it can be downloaded from below location,
http://www.syncfusion.com/downloads/support/forum/119770/SubReportDemo-1005353099.zip
Please refer our MVC ReportViewer(Side By Side sample) online samples on this,
http://mvc.syncfusion.com/demos/web/reportviewer/sidebyside

Please let us know if you have any questions on this.

Regards,
Soundara Rajan S.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;