We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

BannerTextInfo error in Visual Studio Designer

Thread ID:

Created:

Updated:

Platform:

Replies:

119190 Jul 14,2010 05:40 PM UTC May 20,2015 01:05 PM UTC Windows Forms 6
loading
Tags: BannerTextProvider
Administrator [Syncfusion]
Asked On July 14, 2010 05:40 PM UTC

I am in the process of updating our Essential Tools components prior to a final phase of testing and release. I have just upgraded from version 6.302.1.8 to 6.403.0.15 (I appreciate that we are several versions behind the current). If I start with a blank form with a text box and add a BannerTextInfo component and attempt to set the banner text, the IDE responds with the following error message: "Code generation for property "BannerText" failed. Error was "BannerTextInfoTypeConverter" is unable to convert "Syncfusion.Windows.Forms.BannerTextInfo" to "System.ComponentModel.Designer.Serialization.InstanceDescriptor".
I am investigating upgrade to the most recent version available, but in the meantime can you confirm:
1. Is this a known problem with version 6.403.0.15 and are there any known workarounds?
2. Is the problem fixed in a later version of Essential Tools?
3. Is the problem caused by anything environmental on my PC or to do with the way I have installed Essential Tools?

This is a critical problem for us as over half of our forms use the bannertextinfo component an the problem is preventing the designer from loading for each of them.

Thanks for your help
Regards,
Steve G

Administrator [Syncfusion]
Replied On July 15, 2010 10:34 AM UTC

I appear to have fixed the problem. No quite sure how, but the steps I followed were:
1. Uninstalled Essential Tools 6.4.0.15
2. Re-installed Essential Tools 6.4.0.15.
3. I reset the toolbox from within Visual Studio 2005.
4. Re-initialized the Visual Studio .NET toolbox from within the Dashboard.
5. Reloaded my project and removed all of the Syncfusion references from within the solution explorer.
6. Started a new form and added a syncfusion control from the toolbox to force re-creation of the syncfusion assembly references.
All of the form designers including those that use the bannertextinfo component now load OK. My guess is that there was an old reference hanging around somewhere that was causing the problem.

Regards,
Steve Graham

Lingaraj S [Syncfusion]
Replied On July 15, 2010 11:23 AM UTC

Hi Steve,

Thank you for the update.

We are glad to hear that problem has been solved.

This issue seems to appear when we use different framework and assembly reference in Application. Please try the below given steps and let me know if this helps you

1) Open {SyncfusionEssentialStudion Version(eg.8.2.0.30)} Dashboard.
2) Run the AssemblyManger with 'Removeallversion' option. This will remove all the Syncfusion assemblies from GAC and public assemblies folder.
3) If you found any Syncfusion assemblies in GAC and C:\Program Files\Syncfusion\Essential Studio\{SyncfusionEssentialStudion Version(eg.8.2.0.30)}\Assemblies\{FrameWork Version}folder. Please remove it manually all the Syncfusion assemblies.
4) Run the AssemblyManager from the Dashboard and install the {only required version} assemblies.
5) If your Target Framework is {Framework Version(eg.4.0)}, then please remove 2.0 and 3.5 Syncfusion assemblies from GAC and Assemblies folder and vice versa.
6) Please ensure that only required framework assemblies are in GAC (c:\windows\assembly) and also in Assemblies folder (C:\Program Files\Syncfusion\Essential Studio\{SyncfusionEssentialStudion Version(eg.8.2.0.30)} \Assemblies\{2.0 and 3.5})
7) Open the {SyncfusionEssentialStudion Version(eg.8.2.0.30)} Dashboard.
8) Run the Multi Target Framework targeting to {Framework Version(eg.4.0)}
9) Click OK once operation completed successfully.
( Also please try using Toolbox Configuration in Dashboard to install the Syncfusion Tools in the Visual Studio)

Also please try using below steps in your projects.
10) Remove Bin and Obj folder from Project path
11) Open the Visual studio IDE and open the project
12) Rebuild your project.
13) Please check once again the Syncfusion assemblies are referring {SyncfusionEssentialStudion Version(eg.8.2.0.30)}
14) Try these and the issue should be resolved.

Thanks for your contribution in Syncfusion CommunityForums.

Regards,
Lingaraj S.

Administrator [Syncfusion]
Replied On July 21, 2010 04:53 PM UTC

Hi Lingaraj,

Thanks for the update. I have recently renewed my subscription and moved onto version 8.3.0.21 (from 7.3.0.20) but I have been having a few problems with installation which I will deal with under another post.

Regards,

Steve Graham

Lokanath E [Syncfusion]
Replied On July 22, 2010 05:20 AM UTC

Hi Steve,

Thanks for the update,

We will follow up this with the other post.

Thanks for using Syncfusion products.

Regards,
Lokanath.E

Prakash
Replied On May 18, 2015 12:06 PM UTC

Thanks u so much.It's worked

Senthil Kumaran Rajan [Syncfusion]
Replied On May 20, 2015 01:05 PM UTC

Hi Prakash,

Thank you for your update.

Please let us know if you have any further queries.

Regards,
Senthil

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;