We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Error with Gantt in Chrome with 'ejicons.woff?-dzszjm'

Thread ID:

Created:

Updated:

Platform:

Replies:

118750 Apr 7,2015 02:01 PM UTC Apr 8,2015 12:19 PM UTC ASP.NET Web Forms 2
loading
Tags: Gantt
OneTx
Asked On April 7, 2015 02:01 PM UTC

Hello,

I'm implementing Gantt control in my project in Visual Studio 2010 and .Net 4.0
I try to deploy the gantt application to my local server IIS v5.1.

The Gantt run correctly in Firefox browser, but in Chrome the web is freeze.
When we open the Chrome developer tool, we observed the web is freeze when it request "/Content/ej/common-images/ejicons.woff?-dzszjm"  (attached image):

In Firefox browser, the Firebug don't show a request to this file ("ejicons.woff?-dzszjm").


We use the following reference to scripts and CSS:

<%@ Register Assembly="Syncfusion.EJ.Web, Version=12.4400.0.24, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89"
    Namespace="Syncfusion.JavaScript.Web" TagPrefix="ej" %>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="Head1" runat="server">
    <title></title>
    <link rel='nofollow' href="../Content/ej/default-theme/ej.theme.min.css" rel="stylesheet" />
    <link rel='nofollow' href="../Content/ej/ej.widgets.core.min.css" rel="stylesheet" />
    <script src="../Scripts/jquery-1.10.2.min.js" type="text/javascript"></script>
    <script src="../Scripts/jsrender.min.js" type="text/javascript"></script>
    <script src="../Scripts/jquery.easing-1.3.min.js" type="text/javascript"></script>
    <script src="../Scripts/jquery.globalize.min.js" type="text/javascript"></script>
    <script src="../Scripts/modernizr-2.5.3.js" type="text/javascript"></script>
    <script src="../Scripts/ej/ej.web.all.min.js" type="text/javascript"></script>
    <script src="../Scripts/ej/cultures/globalize.culture.es-ES.min.js" type="text/javascript"></script>   
</head>

Our enviroment is Firefox 37.0.1 and Chrome 34.0.1847.137 m

Thanks
Regards






Attachment: Screenshot_2_de22ec03.zip

OneTx
Replied On April 7, 2015 03:03 PM UTC

UPDATE:

We try to fix this problem adding the following MIME type declarations "application/x-font-woff" via IIS Manager without result :(
 (ref. Why is @font-face throwing a 404 error on woff files? )


Mahalakshmi Karthikeyan [Syncfusion]
Replied On April 8, 2015 12:19 PM UTC

Hi OneTx,

Thanks for using Syncfusion product.

We have analyzed on this issue you have reported. We suggest you to do the following options to overcome this,

  1. We have to add the below code in web.config file in Visual studio.


<system.webServer>

<staticContent>

<remove fileExtension=".woff" />

<mimeMap fileExtension=".woff" mimeType="application/font-woff" />

</staticContent>

</system.webServer>



2.Or else we can change in IISExpress definition,


a. It is in ~\Documents\IISExpress\config\applicationhost.config

b. Search for .woff and you can find the below line.

<mimeMap fileExtension=".woff" mimeType="font/x-woff" />



c. Change its mimeType to “application/font-woff”

<mimeMap fileExtension=".woff" mimeType="application/font-woff" />



d. Again restart your application.

We have prepared a sample based on this and you can find the sample under the following location:

Sample: http://www.syncfusion.com/downloads/support/forum/118750/GanttejiconIssue-840383403.zip

Please refer the below link for more details,

http://zduck.com/2013/google-chrome-and-woff-font-mime-type-warnings/

Please let us know if you need more information on this.


Regards,

Mahalakshmi K.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;