We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Data Validation - Allow Non-List Values


In Excel, when setting data validation on a cell so it comes from a drop down list, there is an 'Error Alert' tab which allows you to untick 'Show error alert after invalid data is entered'. How can I set this tickbox to false in IDataValidation ? 
I have tried setting 
.ShowErrorBox & .ShowPromptBox to false, but still get a message box in Excel.


Attachment: 20150109_1858_e8f197f3.zip

3 Replies

SR Sudha Ramachandran Syncfusion Team January 12, 2015 11:04 AM UTC

Hi Shamsul,

Thank you for using Syncfusion products.

We have analyzed your query and are unable to reproduce the issue. We have shared the sample that we tried for your reference. Kindly try the sample at your end and get back to us if the issue is reproducing. If not, please modify the sample to reproduce the issue and get back to us. This will help us to investigate further and provide you a prompt solution. 

Sample Link: http://www.syncfusion.com/downloads/support/directtrac/117925/XlsIOSample-1262624178.zip

Please let us know if you have any queries.


Sudha Ramachandran

AC Anthony Consolati January 14, 2015 05:49 AM UTC


I am setting the .DataSource property, rather than setting a specific list of values. I have discovered that you need to specify the .DataSource property before setting .ShowErrorBox otherwise it will not work. 

DB Dilli Babu Nandha Gopal Syncfusion Team January 15, 2015 05:04 AM UTC

Hi Shamsul,

Thank you for updating us.

The given information about DataSource usage is not sufficient for us to reproduce the issue. Please provide us the code snippet or the sample in which you are able to reproduce the issue. This will help us to give you a prompt solution.


Dilli babu

Live Chat Icon For mobile
Up arrow icon