We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Visible Property set to false falis to hide GridGroupingContrlol

Thread ID:

Created:

Updated:

Platform:

Replies:

116095 Apr 1,2014 11:06 AM Apr 3,2014 11:26 PM ASP.NET Web Forms (Classic) 4
loading
Tags: GridGroupingControl
Alex Segal
Asked On April 1, 2014 11:06 AM

I have a GridGropingControl on a page that is initially hidden by setting Visible="False".

At some point through user interaction I display the control by running GridGroupingControl1.Visible = true.

After that running GridGroupingControl1.Visible = false has no affect on the visibility of the control even though examining the property in the Watch window shows the Visible=false.

What am I missing?

Thank you,

 


Alex Segal
Replied On April 1, 2014 11:50 AM

Additional cue is that it appears that Visible property on GridGroupingControl can only be set once.

For example if it is set to False in the markup, I can set it to true at run time but only once -- it will remain visible in spite of  GridGroupingControl1.Visible = false directive.

Conversely, if it set to nothing in the mark up, it can then only be hidden once at runtime and GridGroupingControl1.Visible = true won't re-display it.


Satheeskumar S [Syncfusion]
Replied On April 2, 2014 01:19 AM

Hi Alex,

Thanks for your interest in Syncfusion Products.

We are sorry about the inconvenience caused. We are unable to reproduce the reported issue. We have prepared the sample using two buttons one is for showing the grid and another one is for hiding the grid. We have hide the grid initially by setting visible property as false in the mark up. In our end showing and hiding of the grid is working fine.

For your convenience we have attached the sample. Could you please refer this sample. If it doesn’t resolve your issue could you please replicate your issue in the above sample and send back to us. So that we could sort out the cause of the issue and provide you with the solution. The information provided would be great help in achieving your requirement.

Please let us know if you need any further assistance.

Regards,

Satheeskumar S


Attachment: SampleApplication_659e79ef.zip

Alex Segal
Replied On April 2, 2014 02:35 PM

Satheeskumar thank you.

I was able to find a work around in which your sample was helpful to examine.


Satheeskumar S [Syncfusion]
Replied On April 3, 2014 11:26 PM

Hi Alex,

Thanks for your update.

We are happy to hear that your issue has been resolved.

Please let us know if you need any further assistance.

Regards,

Satheeskumar S


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;